Jump to content
Калькуляторы

u.s.s.r

Пользователи
  • Content Count

    86
  • Joined

  • Last visited

Everything posted by u.s.s.r


  1. Расшифровал пока так, на PHP $binary=""; $hex_array=explode(" ", $portTrunkAllowedvlan ); foreach ($hex_array as $key => $value) { $binary.=str_pad( base_convert (trim($value), 16, 2) , 8, '0', STR_PAD_LEFT); } $vlans=""; for ($x=0; $x++<mb_strlen($binary)-1;){ if ($binary[$x]){ $vlans.=" $x"; } } echo $vlans;
  2. Нашел такой OID SNMPv2-SMI::enterprises.40418.7.100.3.2.1.20.25 --xxx.100.3.2.1.20 portTrunkAllowedvlan OBJECT-TYPE SYNTAX OCTET STRING MAX-ACCESS read-write STATUS current DESCRIPTION "trunk port allowed vlan list string" ::= { priPortEntry 20 } а как расшифровать?   SNMPv2-SMI::enterprises.40418.7.100.3.2.1.20.25 = Hex-STRING: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 FF 00 00 00 00 00 00 00 00 00 00 00 0F FE 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
  3. А какой OID будет, чтобы узнать наличие тегирования фреймов на порту как такового (switchport trunk allowed vlan для конфигурирования в CLI) ?
  4. Большое спасибо! Добавил в /etc/sudoers Defaults:apache !requiretty Насчет проверки - конечно, куда без этого.
  5. Linux CentOS 6.7 Apache/2.2.26 (Unix) http://127.0.0.1/reload-service.php файл reload-service.php <?php $v=passthru("/usr/bin/whoami", $r); - возвращает "apache" $v=passthru("/usr/bin/sudo /etc/init.d/nginx2 force-reload", $r); - не работает, возвращает код ошибки "1" ?> cat /etc/sudoers ... vista ALL=(root) NOPASSWD: /etc/init.d/nginx2 force-reload apache ALL=(root) NOPASSWD: /etc/init.d/nginx2/nginx2 force-reload если зайти по пользователем "vista", то /usr/bin/sudo /etc/init.d/nginx2 force-reload - восполняется команда
  6. Пытаюсь запустить IPTV с помощью коммутаторов SNR-S2950 Делал по статье http://habrahabr.ru/post/111317/ Но пока безрезультатно. Есть устрояства PBI-5000 (стример) SNR-2950 (в качестве querier'ов) SNR-2950 (на доступе) Текущий конфиг такой ---------SNR-S2950-1---------- Interface Ethernet1/1 description MNG-PBI-5000 switchport access vlan 400 ! Interface Ethernet1/2 description TV-PBI-5000 switchport access vlan 401 Interface Ethernet1/24 description NET switchport mode trunk interface Vlan400 description MNG ip address 192.168.25.2 255.255.255.0 ! interface Vlan401 ip address 10.0.0.10 255.255.255.0 ! ip igmp snooping ip igmp snooping vlan 401 ip igmp snooping vlan 401 l2-general-querier ip igmp snooping vlan 401 l2-general-querier-source 10.0.0.10 ---------SNR-S2950-2---------- Interface Ethernet1/1 description MNG switchport access vlan 400 ! Interface Ethernet1/2 description Client-TV switchport access vlan 401 ! Interface Ethernet1/24 description description NET switchport mode trunk ip igmp snooping ip igmp snooping vlan 401 ip igmp snooping vlan 401 immediately-leave ip igmp snooping vlan 401 mrouter-port interface Ethernet1/24 Пытаемся посмотреть канал в VLC udp://@240.50.0.60:1234 Этот источник не открывается: VLC не может открыть MRL 'udp://@240.50.0.60:1234'. Ищите более подробную информацию в лог-файле.
  7. Снимки на OMNY NVR 32/8 PRO

    1. Поднял сервер FTP 2. Настроил на "OMNY NVR 32/8 PRO" клиент FTP 3. Настроил переодическую передачу снимка на FTP Работало минут 30, пока не решил изменить интервал с 00:00:01 на 23:59:59 и после этого на FTP ничего не заливается, меняю интервал на 00:01:00 ничего, снова делаю 00:00:01 - все так же пусто Доступ к FTP имеется, в том числе и на запись. Включил tcpdump на FTP сервере, слушаю порт 21, с регистратора нет запросов, что я сделал такое, чтоб он перестал высылать снимки? PS: Через некоторое время, почему то интервал сбрасывается на 00:01:00 и все равно через час ничего не приходит Версия: sdk: 4.0.0.3 WEB: 5.0.0.45 kernel: DVRS_v9.0.0.20150518_sp2
  8. Подскажите где можно найти файл mib для HP BladeSystem C7000
  9. Так получилось Interface Ethernet1/3 description WEP-ELTEX ip multicast destination-control access-group 6002 switchport mode hybrid switchport hybrid allowed vlan 11;12 tag switchport hybrid allowed vlan 10 untag switchport hybrid native vlan 10
  10. Возникла необходимость подать мультикаст клиенту по транковому порту, но не понятноо как, вроде сделал как для access, но не работает vlan 40 name multicast multicast-vlan multicast-vlan mode dynamic multicast-vlan association 10 access-list 6000 deny ip any-source any-destination access-list 6002 permit ip any-source any-destination ! multicast destination-control Interface Ethernet1/3 description WEP-12AC ip multicast destination-control access-group 6002 switchport mode trunk switchport allowed vlan 11;12 switchport native vlan 10 ip igmp snooping ip igmp snooping authentication radius none ip igmp snooping authentication forwarding-first ip igmp snooping vlan 40 ip igmp snooping vlan 40 immediately-leave ip igmp snooping vlan 40 l2-general-querier Если перевести порт в access то работает Interface Ethernet1/3 description WEP-12AC ip multicast destination-control access-group 6002 switchport access vlan 10
  11. На данный момент согласен, пришлось микротики подальше выбросить, вернулся на Accel-ppp pptp Микротик CCR1036-12G - максимум 500 сессий тянет, после через сам перезагружается, тарифные скорости это от 2мбит до 15мбит, cpu доходит до 85% Accel-ppp CentOS 6, 4 ведра по 1200мгц 500 сессий, нагрузка на CPU примерно 5-10%, это все при NAT+шейпер+Netflow
  12. Добрый день! Помогите решить проблему, клиенты подключенный к PPPoE серверу не могут выйти в интернет Есть EdgeRouter Version: v1.6.0 Build ID: 4716006 Build on: 10/31/14 17:38 Copyright: 2012-2014 Ubiquiti Networks, Inc. HW model: EdgeRouter Pro 8-Port Пытаюсь на нем поднять PPPoE сервер. Включен маскарадинг, если напрямую (имеется ввиду без авторизации, по IP) то все работает, у клиента прописал так ip 192.168.1.2 шлюз 192.168.1.1 а вот если по PPPoEб клиент получает IP 172.25.25.1 то у него вообще трафик не проходит вот правила маскарадинга Chain POSTROUTING (policy ACCEPT 662 packets, 67394 bytes) pkts bytes target prot opt in out source destination 846 85472 UBNT_VPN_IPSEC_SNAT_HOOK all -- * * 0.0.0.0/0 0.0.0.0/0 41 2612 MASQUERADE all -- * eth5 192.168.1.0/24 0.0.0.0/0 /* NAT-5000 */ 0 0 MASQUERADE all -- * eth5 172.25.25.0/24 0.0.0.0/0 /* NAT-5001 */ но я думаю что проблема не с маскарадингом или какими то там правилоами iptables Дело в том, что выделял и глобальный ip на ppp интерфейс, маршруты прописаны, но трафик даже до виртуального интерфейса ppp не доходит >tracert -d 8.8.8.8 Трассировка маршрута к 8.8.8.8 с максимальным числом прыжков 30 1 * * * Превышен интервал ожидания для запроса. 2 * * * Превышен интервал ожидания для запроса. Я понимаю что слишком мало дал инфомации, если что тонужно выложить, выложу да вот и лог с edgerouter Jun 1 10:33:08 ubnt pppd[4076]: pppd 2.4.4 started by root, uid 0 Jun 1 10:33:08 ubnt pppd[4076]: Connected to 00:30:4f:6d:e0:bb via interface eth0 Jun 1 10:33:08 ubnt pppd[4076]: Connect: ppp0 <--> eth0 Jun 1 10:33:08 ubnt zebra[626]: interface ppp0 index 23 <POINTOPOINT,NOARP,MULTICAST> added. Jun 1 10:33:10 ubnt zebra[626]: interface ppp0 mtu changed from 1500 to 1480 Jun 1 10:33:11 ubnt pppd[4076]: rc_avpair_gen: received unknown attribute 231 of length 4: 0x000003E8 Jun 1 10:33:11 ubnt pppd[4076]: rc_avpair_gen: received unknown attribute 230 of length 4: 0x00000BB8 Jun 1 10:33:11 ubnt pppd[4076]: rc_avpair_gen: received unknown attribute 232 of length 4: 0x00000000 Jun 1 10:33:11 ubnt pppd[4076]: peer from calling number 00:30:4F:6D:E0:BB authorized Jun 1 10:33:11 ubnt zebra[626]: warning: PtP interface ppp0 with addr 10.255.253.0/32 needs a peer address Jun 1 10:33:11 ubnt zebra[626]: interface index 23 was renamed from ppp0 to pppoes0 Jun 1 10:33:11 ubnt zebra[626]: interface pppoes0 index 23 changed <UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>. Jun 1 10:33:11 ubnt pppd[4076]: Cannot determine ethernet address for proxy ARP Jun 1 10:33:11 ubnt pppd[4076]: local IP address 10.255.253.0 Jun 1 10:33:11 ubnt pppd[4076]: remote IP address 172.25.25.1 Может в этом дело? warning: PtP interface ppp0 with addr 10.255.253.0/32 needs a peer address Если да, то как лечится?
  13. Возвращаясь к теме, хотел бы узнать как устранить, один неприятный недостаток в реализации, когда шейпер PCQ и микротику посылают атрибут Mikrotik-Address-List со значением к примеру 12345k, так как 12345k на микротике нет именованного адреса в /ip firewall address-list, то клиент получает всю ширину канала .
  14. И как такая схема будет балансировать нагрузку? С PPPoE нагруженные сервера не успевают отвечать на запросы и новые абоненты подключаются на свободные. ну да, но у нас такая схема работает с pptp распределяется не всегда равномерно, но хоть какая то балансировка есть.
  15. Адресация для доступа к серверу, нужно же ввести его адрес или доменное имя, проблемы с балансировкой нагрузки. PPPoE лишен этих недостатков. Единичка не влезла в поле, попробуйте понизить частоту и увидите что так и есть=) через export compact тоже торчало 200MHz, прописал ручками 1200, стало именно то что должно, наверно конфиг где то слизал и залил насчет балансировки подключение к серверу по доменному имени, а фактических серверов несколько, днс выдает динамически несколько серверов
  16. Это что за глюк? на других стоит 1200 MHz
  17. Я так и не понял в чем проблема с L2TP, о какой адресации речь идет? В микротике я поднял L2TP, кто то с пк с Windows OS автоматом подключился на L2TP, проверил сам, проблем нет с подключением и NAT нормально работает с ним. Сложность в настройке, необходимость выделения IP адресов для транспорта и т.п. а PPTP не просит адреса? или Вы другое имеете ввиду?
  18. Стоит ли перейти на L2TP микротика? или лучше использовать другое железо? Насчет IPoE или PPPоE я в курсе.
  19. Короче реализовал так, надо будет на боевом микротике проверить, посмотрим что получится Биллинг шлет радиус-атрибут "Mikrotik-Address-List" со значением "30M" /queue type add kind=pcq name=TEST_30M_down pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=30M pcq-src-address6-mask=64 pcq-total-limit=6400000 add kind=pcq name=TEST_30M_up pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=30M pcq-src-address6-mask=64 pcq-total-limit=6400000 /queue tree add name=Total_download parent=global priority=1 queue=default add name=Total_upload parent=global priority=1 queue=default add name=TEST_30M_up packet-mark=TEST_30M_up parent=Total_upload priority=1 queue=TEST_30M_up add name=TEST_30M_down packet-mark=TEST_30M_down parent=Total_download priority=1 queue=TEST_30M_down /ip firewall address-list add address=172.29.1.1-172.29.1.254 list=30M /ip firewall mangle add action=mark-packet chain=forward new-packet-mark=TEST_30M_up passthrough=no src-address-list=30M add action=mark-packet chain=forward dst-address-list=30M new-packet-mark=TEST_30M_down passthrough=no
  20. у меня же шейпинг через радиус-атрибуты, так тут дело получается в приоритетах проблема?
  21. мы от темы отклонились, хоть какое то объяснение будет, почему возникают тормоза?
  22. потому что "коробка" нужна
  23. Добрый день, точно такая же проблема наблюдается и у меня. Большие потери пакетов возникают. Перед настройкой делал сброс конфига на Микротике На данный момент вернулся пока на Accel-PPP 1.8 1) В момент проблемы нагрузка на CPU 5% 2) Шейпинг через радиус-атрибут Mikrotik-Rate-Limit передаю значения в таком виде 500k или 2000k в зависимости от тарифного плана 2) У клиентов скорости на тарифах от 500кбит до 3Мбит 3) Используется на микротике шейпинг. NAT, DHCP, NetFlow (пока убрал), PPPoE+радиус 5) Схема сети следующая: --- SNR-s2950 (клиенты PPPoE) Интернет ---- Микротик --- SNR-s2980g-24T --- SNR-s2980g-24T --- SNR-s2950 (клиенты PPPoE) --- SNR-s2950 (клиенты PPPoE) /system resource print uptime: 9h31m42s version: 6.23 build-time: Dec/04/2014 14:46:06 free-memory: 3687.9MiB total-memory: 3969.2MiB cpu: tilegx cpu-count: 36 cpu-frequency: 1200MHz cpu-load: 0% free-hdd-space: 904.5MiB total-hdd-space: 1024.0MiB architecture-name: tile board-name: CCR1036-8G-2S+ platform: MikroTik admin@PPPoE] [admin@PPPoE] > export compact # mar/27/2015 13:29:43 by RouterOS 6.23 # software id = YRFU-I8D8 # /interface ethernet set [ find default-name=ether1 ] comment="SNR.INET.7 port" l2mtu=1590 name="1. WAN" set [ find default-name=ether2 ] comment="SNR.5km.9 port" l2mtu=1590 name="2. 5km" set [ find default-name=ether3 ] comment="SNR.5km 11 port" l2mtu=1590 name="3. GePON" set [ find default-name=ether4 ] comment="SNR.5km 13 port" l2mtu=1590 name="4. ADSL" set [ find default-name=ether8 ] comment="SNR.5km 2 port" l2mtu=1590 name="8. MNG" set [ find default-name=ether5 ] disabled=yes l2mtu=1590 set [ find default-name=ether6 ] disabled=yes l2mtu=1590 set [ find default-name=ether7 ] disabled=yes l2mtu=1590 set [ find default-name=sfp-sfpplus1 ] disabled=yes l2mtu=1590 set [ find default-name=sfp-sfpplus2 ] disabled=yes l2mtu=1590 /ip neighbor discovery set "1. WAN" comment="SNR.INET.7 port" set "2. 5km" comment="SNR.5km.9 port" set "3. GePON" comment="SNR.5km 11 port" set "4. ADSL" comment="SNR.5km 13 port" set "8. MNG" comment="SNR.5km 2 port" /interface vlan add interface="3. GePON" l2mtu=1586 name=vlan.401 vlan-id=401 add interface="3. GePON" l2mtu=1586 name=vlan.403 vlan-id=403 add interface="2. 5km" l2mtu=1586 name=vlan.501 vlan-id=501 # еще 35 VLAN-интерефейсов /ip pool add name=PPPoE.501 ranges=172.29.1.2-172.29.1.254 ... add name=IP.501 ranges=10.30.1.3-10.30.1.254 ... add name=PPPoE.601 ranges=172.29.101.2-172.29.101.254 ... add name=IP.601 ranges=10.55.1.3-10.55.1.254 ... /ip dhcp-server add address-pool=IP.501 disabled=no interface=vlan.501 lease-time=1d name=dhcp.501 ... /port set 0 name=serial0 set 1 name=serial1 /ppp profile add dns-server=8.8.8.8,8.8.4.4 local-address=172.25.1.1 name=PPPoE.501 remote-address=PPPoE.501 use-compression=no use-encryption=no use-mpls=no use-vj-compression=no ... /system logging action set 3 src-address=0.0.0.0 /interface pppoe-server server add authentication=chap,mschap1,mschap2 default-profile=PPPoE.501 interface=vlan.501 max-mru=1480 max-mtu=1480 mrru=1600 service-name=PPPoE.501 ... /ip address add address=1.1.1.1/27 comment=WAN.Internet interface="1. WAN" network=1.1.1.0 add address=192.168.113.251/25 comment=MNG interface="8. MNG" network=192.168.113.128 add address=10.30.1.2/24 comment=NET.5km interface=vlan.501 network=10.30.1.0 ... /ip dhcp-server network add address=10.30.1.0/24 dns-server=10.30.1.1 gateway=10.30.1.1 ... /ip firewall filter add chain=input comment="Allow Ping" protocol=icmp add chain=forward disabled=yes protocol=icmp add chain=input comment="Accept established connections" connection-state=established add chain=forward connection-state=established disabled=yes add chain=input comment="Accept related connections" connection-state=related add chain=forward connection-state=related disabled=yes add action=drop chain=input comment="Drop invalid connections" connection-state=invalid add action=drop chain=forward connection-state=invalid disabled=yes add chain=input comment="Allow UDP" protocol=udp add chain=forward disabled=yes protocol=udp add action=drop chain=forward comment="Drop betwenn ppp" in-interface=all-ppp out-interface=all-ppp add chain=forward comment="Access to Internet from local network" src-address=172.29.0.0/16 add chain=forward dst-address=172.29.0.0/16 add chain=input comment="Access to Mikrotik only from our local network" src-address=192.168.88.0/24 add chain=input src-address=192.168.113.128/25 add action=drop chain=input comment="All other drop" add action=drop chain=forward add action=drop chain=input dst-port=80 protocol=tcp /ip firewall nat add action=src-nat chain=srcnat disabled=yes src-address=172.29.0.0/16 to-addresses=1.1.1.100 add action=src-nat chain=srcnat comment=v.501 src-address=172.29.1.0/24 to-addresses=1.1.1.102 add action=src-nat chain=srcnat comment=v.504 src-address=172.29.4.0/24 to-addresses=1.1.1.1.103 add action=src-nat chain=srcnat comment=v.505 src-address=172.29.5.0/24 to-addresses=1.1.1.1.104 ... /ip ipsec policy set 0 dst-address=0.0.0.0/0 src-address=0.0.0.0/0 /ip proxy set cache-path=web-proxy1 /ip route add distance=1 gateway=1.1.1.2 /ip traffic-flow set enabled=yes interfaces="1. WAN" /ip traffic-flow target add address=2.2.2.2:9996 version=5 /ppp aaa set interim-update=2m use-radius=yes /radius add accounting-port=1819 address=2.2.2.2 authentication-port=1818 secret=adminplatexppp service=ppp src-address=1.1.1.1 timeout=1s /radius incoming set accept=yes port=3779 /system clock set time-zone-name=Asia/Yekaterinburg /system identity set name=PPPoE /system leds set 0 type=interface-speed set 2 type=interface-speed /system logging add disabled=yes topics=radius /system routerboard settings set cpu-frequency=1200MHz memory-frequency=1066DDR