Перейти к содержимому
Калькуляторы

gendolf_gray

Пользователи
  • Публикации

    3
  • Зарегистрирован

  • Посещение

О gendolf_gray

  • Звание
    Абитуриент
  1. accel pptpd

    я не буду говорить про звезды, видимо это что-то другое с моими руками. Сегодня поднял тестовую виртуалку с CentOS 5.4 64 бита, далее yum update имеющихся пакетов. #yum install kernel-headers kernel-devel gcc #git clone git://accel-pptp.git.sourceforge.net/gitroot/accel-pptp/accel-pptp #cd accel-pptp; make server && make server_install #depmod ; modprobe pptp и модуль удачно загрузился в ядро Nov 23 09:38:45 vpn-test.example.com kernel: PPTP driver version 0.8.4 После чего уже на железном сервер с CentOS 5.4 , но 32бита сделал yum update, обновился ppp до ppp-2.4.4-14.1.rhel5.i386.rpm и далее #yum install kernel-headers kernel-devel gcc #git clone git://accel-pptp.git.sourceforge.net/gitroot/accel-pptp/accel-pptp #cd accel-pptp; make server && make server_install #depmod ; modprobe pptp модуль удачно подгрузился в ядро Nov 23 09:43:12 vpn.example.com kernel: PPTP driver version 0.8.4 Главное в Git ничего не менялось за ночь http://accel-pptp.git.sourceforge.net/git/...-pptp;a=summary Всем спасибо за помощь.
  2. accel pptpd

    depmod отработал, далее могу делать modinfo modinfo # modinfo pptp filename: /lib/modules/2.6.18-164.6.1.el5/extra/pptp.ko license: GPL author: Kozlov D. (xeb@mail.ru) description: Point-to-Point Tunneling Protocol for Linux srcversion: 5D2F5FCC34E482AE7F5DF9A depends: pppox,ppp_generic vermagic: 2.6.18-164.6.1.el5 SMP mod_unload 686 REGPARM 4KSTACKS gcc-4.1 parm: log_packets:int parm: log_level:Logging level (default=0) (int) # modprobe # modprobe pptp FATAL: Error inserting pptp (/lib/modules/2.6.18-164.6.1.el5/extra/pptp.ko): Unknown symbol in module, or unknown parameter (see dmesg) # tail /var/log/messages Nov 23 08:05:43 vpn.example.com kernel: pptp: Unknown symbol __you_cannot_kzalloc_that_much подскажите какую версию accel-pptp ставили, ядро ведь на CentOS родное?
  3. accel pptpd

    Подскажите пожалуйста возможно ли на CentOS 5.4 i386 держать VPN сервер используя accel-pptp, здесь все запускают его уже на новых ядрах и складывается впечатление, что на 2.6.18 accel-pptp работать не будет. ядро: Linux vpn.example.com 2.6.18-164.6.1.el5 #1 SMP Tue Nov 3 16:18:27 EST 2009 i686 i686 i386 GNU/Linux Я делаю следующее: #yum install kernel-headers kernel-devel gcc #git clone git://accel-pptp.git.sourceforge.net/gitroot/accel-pptp/accel-pptp #cd accel-pptp; make server && make server_install все успешно собирается и устанавливается далее я вижу что pptp модуль лежит в /lib/modules/2.6.18-164.6.1.el5/extra/ но ни modprobe ни modinfo про него ничего не говорят # modprobe pptp FATAL: Module pptp not found. # modinfo pptp modinfo: could not find module pptp # insmod на файл выдает следующее # insmod pptp.ko insmod: error inserting 'pptp.ko': -1 Unknown symbol in module #