Перейти к содержимому
Калькуляторы

papengul

Новичок
  • Публикации

    2
  • Зарегистрирован

  • Посещение

О papengul

  • Звание
    Абитуриент
  1. Вижу вот такое apt-cache show postgis Depends: libc6 (>= 2.4), libglib2.0-0 (>= 2.12.0), libgtk2.0-0 (>= 2.8.0), libpq5 (>= 8.4~) apt-cache show postgresql-9.1-postgis Depends: libc6 (>= 2.4), libgeos-c1 (>= 3.2.2), libproj0, libxml2 (>= 2.7.4), postgis, postgresql-9.1 Conflicts: postgis (<< 1.2.1) Ради интереса поправил скрипт, и сделал установку postgresql-9.1-postgis2 NOC встал и удалось попасть на WEB мордие но неработает хорошая часть функционала
  2. Доброго времени суток. пытаюсь поставить NOC на 12.04 ubuntu Вот что получаю Некоторые пакеты невозможно установить. Возможно, вы просите невозможного, или же используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, поможет вам: Пакеты, имеющие неудовлетворённые зависимости: postgresql-9.1-postgis : Зависит: postgis но он не будет установлен E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты. sh: Failed to install postgresql-9.1-postgis Terminating root@noc:/home/op# apt-get install postgis Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Следующие пакеты устанавливались автоматически и больше не требуются: libavutil51 liblcms1 python-numpy libcupsimage2 liblwgeom-2.0.3 libxxf86dga1 libicu48 x11-utils libjbig2dec0 xterm python-imaging libspeex1 libogdi3.2 libfftw3-3 libgs9-common libavcodec53 libgdal1-1.7.0 xbitmaps libxaw7 libijs-0.35 libvpx1 libxerces-c28 cmap-adobe-japan1 libtheora0 lesstif2 libxmu6 libxpm4 gs-cjk-resource libgsm1 libvorbisenc2 libspatialite3 libschroedinger-1.0-0 libxss1 libgs9 libavformat53 tcl8.5 libfontenc1 libgeos-3.2.2 libxtst6 libutempter0 tk8.5 ghostscript python-support libva1 libglu1-mesa libpaper-utils libvorbis0a libxcb-shape0 libxp6 libxt6 libxv1 freeglut3 gsfonts libpaper1 libogg0 python-opengl grass-doc Для их удаления используйте «apt-get autoremove». Будут установлены следующие дополнительные пакеты: libgdal1h Предлагаемые пакеты: postgresql-9.1-postgis-2.1 postgis-doc Пакеты, которые будут УДАЛЕНЫ: libgdal1 НОВЫЕ пакеты, которые будут установлены: libgdal1h postgis обновлено 0, установлено 2 новых пакетов, для удаления отмечено 1 пакетов, и 0 пакетов не обновлено. Необходимо скачать 0 B/5 667 kB архивов. После данной операции, объём занятого дискового пространства возрастёт на 581 kB. Хотите продолжить [Д/н]? N Аварийное завершение. Т.е я не могу установить postgresql-9.1-postgis пока я не установлю postgis А postgis требует libgdal1h и сносит libgdal1 без которой не встанет postgresql-9.1-postgis. Это как нить лечится ? Заранее спасибо за ответ