Jump to content
Калькуляторы

budda555

Пользователи
  • Content Count

    40
  • Joined

  • Last visited

Posts posted by budda555


  1. Доброго времени суток, господа!

    Кто нибудь отдовал IPv6 клиентам через OLT BDcom?

    Топология: post-64496-067809200 1450512610_thumb.png

    При такой схеме P3616-2TE(OLT) видит всех, клиент видит только P3616-2TE(OLT), поверх P3616-2TE(OLT) все видят друг друга.

    а зачем вам вообще ipv6 ?

    Да хрен его знает, просто в ближайшем будущем наверняка будет принят закон об необходимости выдавать клиентам белые адреса, а с нашим запасом IPv4 придется переходить на другие железки.

  2. Доброго времени суток, господа!

    Кто нибудь отдовал IPv6 клиентам через OLT BDcom?

    Топология: post-64496-067809200 1450512610_thumb.png

    При такой схеме P3616-2TE(OLT) видит всех, клиент видит только P3616-2TE(OLT), поверх P3616-2TE(OLT) все видят друг друга.

  3. Смысле неправильно? у тебя влан3333 смотрит в клиентов?

    На интерфейсе один адрес, а у репортеров из другой сети

     

    VLAN3333 239.255.67.250 00:48:23 00:01:45 10.8.45.2 R

    VLAN3333 239.255.255.246 00:48:39 00:01:51 10.8.47.3 R

    VLAN3333 224.0.0.253 03:11:09 00:01:46 10.8.44.6 R

    VLAN3333 233.89.188.1 03:33:06 00:01:42 10.8.43.145 R

     

    или я неправильно понимаю?

    Моя группа 239.10.10.0/24, фильтр просто не работает почему-то.

    Я прописовал:

    ip access-list standard rp.iptv
    permit  239.10.10.0 255.255.255.0

    не работает.

  4. Проблема решена.

    нужна команда промиск моде в секции igmp interface.

    комментарий навел на идею сделать что-то в этом духе и полетело, на интерфейсе влан 3333 прописал следующее:

    no ip igmp validate report-source

     

    Сейчас подписки бегут до 3928 и все работает, даже если клиент с другого сегмента сети.

    Но я опять же настаиваю на том, что конфиг неверный.

  5. Ну все верно, просто в первый раз вы написали "Регистр-стоп отправляется если получателей нет" а это неверно.

     

    Регистр-стоп отправляется независимо от того есть получатели или нет.

     

    Разница в том, если получатели есть, RP инициирует PIM-Join в сторону FHR, для того чтобы FHR переключился на чистый мультикаст.

    А если получателей нет, FHR получает регистр-стоп и не получает PIM-JOin, то он засыпает на время (3мин в зависимости от вендора)

    Это ответ на мой вопрос?

    Нет.

     

    Теперь по тебе.

     

    Смотри, у тебя на влан3333 прибит ip address 10.11.11.1 255.255.255.0

    А получатели из другой подсети.

    Например в джунипере такой репорт не пройдет. нужна команда промиск моде в секции igmp interface.

    В твоей коробке хз как это будет работать.

    Если дебаги смотреть не умеешь, тогда сделай так, чтоб получатель и источник видели друг друга по юникасту. Потом будем разбираться дальше

     

    Смотри, сейчас я на влан3333 прибил ip address 10.8.0.1/16, (/16)для того, чтобы была возможность при необходимости поднимать хотя бы 254 влан интерфейсов, которые будут бегать через OLT, и как ты говоришь влан3333 интерфейс на 3928GX-B видел по крайней мере всю вышеупомянутую сеть.

    Но это же не правильно.

  6. Ну все верно, просто в первый раз вы написали "Регистр-стоп отправляется если получателей нет" а это неверно.

     

    Регистр-стоп отправляется независимо от того есть получатели или нет.

     

    Разница в том, если получатели есть, RP инициирует PIM-Join в сторону FHR, для того чтобы FHR переключился на чистый мультикаст.

    А если получателей нет, FHR получает регистр-стоп и не получает PIM-JOin, то он засыпает на время (3мин в зависимости от вендора)

    Это ответ на мой вопрос?

  7. Это все максимально понятно, есть хорошие статьи на Хабре.

    Я прошу объяснить мне следующее:

    1. Есть клиент подключенный через P1501C1 к OLT с IP address - 10.9.9.9/24

    Отправляю запрос на подписку к группе - 239.10.10.1

    На OLT в ответ на:

    show ip mcst g

    получаю:

    Total Group Counts: 1
    
    Vlan Group           Type     Port(s)
    ---- --------------- -------- -------------------------------------
    3333 239.10.10.1     LEARNING EPON0/2:1

     

    На 3928GX-B в ответ на:

    show ip igmp g

    получаю:

    Total igmp group number:  8
    
    interface: VLAN3333  :  igmp group number: 8
    
    Interface        Group address    Uptime    Expires   Last Reporter    Flags
    VLAN3333         224.0.0.251      00:04:48  00:01:46  10.8.37.2        R
    VLAN3333         224.0.0.252      00:09:58  00:01:50  10.8.49.2        R
    VLAN3333         239.255.255.250  00:15:13  00:01:51  10.8.44.4        R
    VLAN3333         239.192.152.143  00:36:29  00:01:49  10.8.43.13       R
    VLAN3333         239.255.67.250   00:48:23  00:01:45  10.8.45.2        R
    VLAN3333         239.255.255.246  00:48:39  00:01:51  10.8.47.3        R
    VLAN3333         224.0.0.253      03:11:09  00:01:46  10.8.44.6        R
    VLAN3333         233.89.188.1     03:33:06  00:01:42  10.8.43.145      R

    --------------------------------------------------------------------------------

     

    Если у клиента IP address меняю на - 10.8.9.9/24

    На 3928GX-B в ответ на:

    show ip igmp g

    получаю:

    Total igmp group number:  9
    
    interface: VLAN3333  :  igmp group number: 9
    
    Interface        Group address    Uptime    Expires   Last Reporter    Flags
    VLAN3333         239.10.10.1      00:00:43  00:01:58  10.8.9.9         R
    VLAN3333         224.0.0.252      00:02:21  00:01:58  10.8.50.2        R
    VLAN3333         224.0.0.251      00:04:11  00:01:59  10.8.43.3        R
    VLAN3333         239.255.255.250  00:20:05  00:01:59  10.8.43.12       R
    VLAN3333         239.192.152.143  00:41:21  00:01:59  10.8.43.13       R
    VLAN3333         239.255.67.250   00:53:15  00:01:54  10.8.45.2        R
    VLAN3333         239.255.255.246  00:53:31  00:01:58  10.8.47.3        R
    VLAN3333         224.0.0.253      03:16:01  00:01:59  10.8.44.6        R
    VLAN3333         233.89.188.1     03:37:58  00:01:56  10.8.43.145      R

  8. Неверно, RP отправляет register stop, если получатели есть, тем самым говорит FHR'у - посылай мне чистый мультикаст.

    У него 1 роутер, т.е. сам на себе регает источника. И должно быть 2 туннельных интерфейса, один для инкапсуляции мультикасата, 2й для декапсуляции, вывод которых до сих пор не предоставлен

    Может речь идет об этом?

    3928GX_config#show ip igmp interface ?           
     GigaEthernet      -- GigaEthernet interface
     TGigaEthernet     -- Ten GigaEthernet interface
     Vlan              -- VLAN interface
     Port-aggregator   -- Ethernet aggregation interface
     Null              -- Null interface
     Loopback          -- Loopback interface
     SuperVlan         -- SuperVLAN interface
     Tunnel            -- Tunnel interface
       |         -- Output modifiers
       <cr>

     

    3928GX_config#show ip igmp interface Tunnel 
    show ip igmp interface Tunnel 
                           ^
    Unknown command

  9. Самое странное то, что по этому конфигу все работает, но я то понимаю, что конфиги неверные.

    Еще раз на всякий случай поделюсь тем, что имею на данный момент:

     

    1. Клиентский IP address должен быть в том же сегменте сети, что и настроенный на 3928GX-B интерфейс (в моем примере это)

    interface VLAN3333
    ip address 10.8.0.1 255.255.0.0
    no ip directed-broadcast
    ip pim-sm
    ip igmp enable
    ip igmp version 2

     

    Конечно же это русский метод (открываем кран подачи топлива ломом, на космической станции «Мир», Армагеддон (фильм, 1998) ), но главное, что работает!

  10. Причем тут mdt?

    show ip pim-sm interfaces

    или я хз какая там у тебя команда.

    Стандартную процедуру регистрации источника на RP никто, я думаю, не отменял, даже если это 1 роутер.

    Поэтому у тебя должно быть 2 туннеля

    На циске так:

    R7#show ip pim tunnel

    Tunnel0

    Type : PIM Encap

    RP : 1.1.0.1*

    Source: 1.1.0.1

    Tunnel1*

    Type : PIM Decap

    RP : 1.1.0.1*

    Source: -

     

    Tunnel0 1.1.0.1 YES unset up up

    Tunnel1 1.1.0.1 YES unset up up

     

     

    show ip pim-sm interface

     

    Intf       Address            Ver/   Nbr    Hello  DR     DR
                                 Mode   Count  Intvl  Prior  Addr
    v3333      10.8.0.1           V2/S   0      30     1      10.8.0.1
    v1111      10.10.10.100       V2/S   1      30     1      10.10.10.100

     

    может с мануала начать?

     

    Дело в том, что BDCOM мануалами не балует, а сходство в софте, это еще не значит, что под рукой у меня CISCO.

  11. Причем тут mdt?

    show ip pim-sm interfaces

    или я хз какая там у тебя команда.

    Стандартную процедуру регистрации источника на RP никто, я думаю, не отменял, даже если это 1 роутер.

    Поэтому у тебя должно быть 2 туннеля

    На циске так:

    R7#show ip pim tunnel

    Tunnel0

    Type : PIM Encap

    RP : 1.1.0.1*

    Source: 1.1.0.1

    Tunnel1*

    Type : PIM Decap

    RP : 1.1.0.1*

    Source: -

     

    Tunnel0 1.1.0.1 YES unset up up

    Tunnel1 1.1.0.1 YES unset up up

     

     

    show ip pim-sm interface

     

    Intf       Address            Ver/   Nbr    Hello  DR     DR
                                 Mode   Count  Intvl  Prior  Addr
    v3333      10.8.0.1           V2/S   0      30     1      10.8.0.1
    v1111      10.10.10.100       V2/S   1      30     1      10.10.10.100

  12. да не то ж.. sh ip pim tunnel или че-нить в таком духе

    3928GX_config#show ip pi
    pim-dm  pim-sm  
    3928GX_config#show ip pim-sm ?
     anycast-rp  -- Display register packet rcv and send for anycast-rp
     bsr-router  -- Display PIM-SM bootstrap (BSR) information
     interface   -- Display PIM-SM interfaces information
     mdt         -- Multicast tunnel information
     neighbor    -- Display PIM-SM neighbor information
     protocol    -- Protocol independent multi-cast protocol sparse mode
     rp          -- Display PIM-SM RP information
     rp-hash     -- Display the RP according to the hash
     sz-info     -- Display PIM-SM sz information
     vrf         -- Display pimsm VPN Routing/Forwarding instance
    3928GX_config#show ip pim-sm 

  13. Просто я так понимаю, что OLT не хочет выступать в качестве Reporter, в качестве Last Reporter выступают клиенты.

     

    show ip igmp g

     

    Interface        Group address    Uptime    Expires   Last Reporter    Flags
         VLAN3333         239.10.10.2      08:34:25  00:01:11  10.8.222.222     R
         VLAN3333         239.10.10.6      11:27:44  00:01:10  10.8.41.2        R
    

     

    По такому же принципу к D-link DGS-3620-28TC подключен другой OLT.

    В ответ на:

    show igmp group

     

    Interface     Multicast Group  Last Reporter    IP Querier       IP Expire
    ------------  ---------------  ---------------  ---------------  ---------
         Multicast     239.10.10.1      10.0.0.200       SELF             242
         Multicast     239.10.10.2      10.0.0.200       SELF             248
    

     

    Тут видно, что в качестве Last Reporter выступает сам OLT, а не клиенты, так как 10.0.0.200 это дефолтный Querier address OLT.

  14. На s5612 счётчики мультикаст на эгрес растут? С какой скростью?

     

    S5612 (tgigaEthernet 1/7) смотрит в сторону 3928GX-B

     

    show interface tgigaEthernet 1/7

    TGigaEthernet1/7 is up, line protocol is up
     Ifindex is 15, unique port number is 7
     Description: S3928GX-B
     Hardware is 10Giga-FX, address is 00e0.0f45.0c5d (bia 00e0.0f45.0c5d)
     MTU 1500 bytes, BW 10000000 kbit, DLY 10 usec
     Encapsulation ARPA
     Full-duplex,  10000Mb/s,  Flow-Control Off
     5 minutes input rate 5838668 bits/sec, 1588 packets/sec
     5 minutes output rate 564329030 bits/sec, 51878 packets/sec
        Received 995224 packets, 466882488 bytes
        831 broadcasts, 992873 ucasts  1520 multicasts
        0 FCS, 0 PAUSE  0 jabber, 0 jumbo
        0 undersize, 0 collision
        0 error, 0 allignment
        0 overrun, 116445 oversize
        0 63B packets, 99 64B packets
        614887 65B~127B packets, 72629 128B~255B packets
        7676 256B~511B packets, 48099 512B~1023B packets
        116445 good 1519B packets, 0 bad 1519B packets
        Transmited 31991082 packets, 43458351567 bytes
        4519 broadcasts, 1352896 ucasts  30633656 multicasts
        0 FCS, 0 jumbo 0 underrun
        0 63B packets, 14719 64B packets
        183877 65B~127B packets, 80836 128B~255B packets
        21258 256B~511B packets, 21886 512B~1023B packets
        918250 good 1519B packets

  15. т.е. у стримера порт 10G или всё же через промежуточный свитч? дайте сразу как всю полезную инфу, ещё немного и ни у кого не будет терпения выпытывать её из вас

    Так, cхема топологии с нуля, до клиента.

    Topology.png

     

    Vlan 1111 ходит до BDCOM 3928GX-B (TGigaEthernet1/1) транком.

    В скором времени стример будет подключен прямо на BDCOM S5612 через 10GB.

  16. budda555

    А у вас в vlan1111 непрерывно идёт мультикаст(в него безусловно дуют стримеры?) или же нужен igmp-join, чтоб мультикаст потёк в vlan1111?

     

    нарисуйте схему, что находится за TGigaEthernet1/1

     

    На интерфейс TGigaEthernet1/1 в vlan1111 тупо льется мультикаст поток 600мб/c.

  17. После:

    router pim-sm
     static-rp 10.10.10.100

     

    show ip mroute pim-sm

     

    (10.10.10.11,     239.10.10.5)          RP:10.10.10.100      creat time:1d12h40m  SPT 
     Upstream interface: v1111, rpf' nbr: 10.10.10.11  
     ps inh_olist list:
       n0,   
    
    (*, 239.10.10.6)       RP:10.10.10.100      creat time:00:02:55  *G  
     Upstream interface: n0, rpf' nbr: 0.0.0.0  
     ps imm_olist list:
       v3333,
    
    (10.10.10.11,     239.10.10.6)          RP:10.10.10.100      creat time:1d12h40m  SPT 
     Upstream interface: v1111, rpf' nbr: 10.10.10.11  
     ps inh_olist list:
       v3333,
       n0,

  18. !
    ip access-list standard rp.iptv
    permit  239.10.10.0 0.0.0.255
    !

     

    router pim-sm
     static-rp 10.10.10.100 rp.iptv override
    

     

    show ip mrouter pim-sm

    show ip mroute pim-sm 
    IP PIM-SM Multicast Routing Table:
    
    (*, 224.0.0.251)       RP:0.0.0.0           creat time:00:03:19  *G  
     Upstream interface: v999, rpf' nbr: 185.57.68.1  
     ps imm_olist list:
       v3333,
    
    (*, 224.0.0.252)       RP:0.0.0.0           creat time:00:10:57  *G  
     Upstream interface: v999, rpf' nbr: 185.57.68.1  
     ps imm_olist list:
       v3333,
    
    (*, 224.0.0.253)       RP:0.0.0.0           creat time:00:50:57  *G  
     Upstream interface: v999, rpf' nbr: 185.57.68.1  
     ps imm_olist list:
       v3333,
    
    (*, 233.89.188.1)      RP:0.0.0.0           creat time:00:44:14  *G  
     Upstream interface: v999, rpf' nbr: 185.57.68.1  
     ps imm_olist list:
       v3333,
    
    (10.10.10.11,     239.10.10.1)          RP:0.0.0.0           creat time:1d12h09m  SPT 
     Upstream interface: v1111, rpf' nbr: 10.10.10.11  
     ps inh_olist list:
       n0,
    
    (10.10.10.11,     239.10.10.2)          RP:0.0.0.0           creat time:1d12h09m  SPT 
     Upstream interface: v1111, rpf' nbr: 10.10.10.11  
     ps inh_olist list:
       n0,
    
    (*, 239.10.10.3)       RP:0.0.0.0           creat time:01:26:34  *G  
     Upstream interface: v999, rpf' nbr: 185.57.68.1  
     ps imm_olist list:
       v3333,
    
    (10.10.10.11,     239.10.10.3)          RP:0.0.0.0           creat time:1d12h09m  SPT 
     Upstream interface: v1111, rpf' nbr: 10.10.10.11  
     ps inh_olist list:
       v3333,
       n0,

     

    show ip pim-sm rp

    GROUP: 224.0.0.251
      RP: 0.0.0.0
    
    GROUP: 224.0.0.252
      RP: 0.0.0.0
    
    GROUP: 224.0.0.253
      RP: 0.0.0.0
    
    GROUP: 233.89.188.1
      RP: 0.0.0.0
    
    GROUP: 239.10.10.3
      RP: 0.0.0.0
    
    GROUP: 239.192.152.143
      RP: 0.0.0.0
    
    GROUP: 239.255.67.250
      RP: 0.0.0.0
    
    GROUP: 239.255.255.177
      RP: 0.0.0.0
    
    GROUP: 239.255.255.246
      RP: 0.0.0.0
    
    GROUP: 239.255.255.250
      RP: 0.0.0.0

  19. budda555

    Дайте диагностику типа такой(команды Cisco, ищите подобные у BDCOM):

    show ip pim nei

    show ip mroute

    show ip pim rp

     

    С каких ip.src вещает стример? пройдут ли они RPF-проверку?

     

    В ответ на:

    show ip mroute pim-sm, кусок кода

    (*, 239.10.10.1)       RP:0.0.0.0           creat time:1d04h37m  *G  
     Upstream interface: v999, rpf' nbr: 185.57.68.1  
     ps imm_olist list:
       v3333,
    
    (10.10.10.11,     239.10.10.1)          RP:0.0.0.0           creat time:1d11h37m  SPT 
     Upstream interface: v1111, rpf' nbr: 10.10.10.11  
     ps inh_olist list:
       v3333,
       n0,
    
    (10.10.10.11,     239.10.10.2)          RP:0.0.0.0           creat time:1d11h37m  SPT 
     Upstream interface: v1111, rpf' nbr: 10.10.10.11  
     ps inh_olist list:
       n0,
    
    (*, 239.10.10.3)       RP:0.0.0.0           creat time:00:54:51  *G  
     Upstream interface: v999, rpf' nbr: 185.57.68.1  
     ps imm_olist list:
       v3333,
    
    (10.10.10.11,     239.10.10.3)          RP:0.0.0.0           creat time:1d11h37m  SPT 
     Upstream interface: v1111, rpf' nbr: 10.10.10.11  
     ps inh_olist list:
       v3333,
       n0,

     

    Ответ на:

    show ip pim-sm rp

    GROUP: 224.0.0.251
      RP: 0.0.0.0
    
    GROUP: 224.0.0.252
      RP: 0.0.0.0
    
    GROUP: 224.0.0.253
      RP: 0.0.0.0
    
    GROUP: 233.89.188.1
      RP: 0.0.0.0
    
    GROUP: 239.10.10.1
      RP: 0.0.0.0
    
    GROUP: 239.10.10.3
      RP: 0.0.0.0
    
    GROUP: 239.192.152.143
      RP: 0.0.0.0
    
    GROUP: 239.255.67.250
      RP: 0.0.0.0
    
    GROUP: 239.255.255.246
      RP: 0.0.0.0
    
    GROUP: 239.255.255.250
      RP: 0.0.0.0

  20. Тут я вижу все умные очень, прямо как у нас!

    Просто не могу понять, что именно Вам не ясно?

    Есть 3928GX, на нем настроена PIM-SM маршрутизация.

    Стример подключен к 3928GX - TGigaEthernet1/1, к GigaEthernet0/21 подключен OLT.

    Так вот, если клиентский ip адрес, который в свою очередь подключен через ONU P1501C1 к OLT interface EPON0/2, не в сегменте

    interface VLAN3333
    ip address 10.11.11.1 255.255.255.0

    подписки нет на 3928GX.

  21. Добрый день!

     

    Если у кого-то есть опыт настройки PIM-SM на BDCOM S3928GX-B, прошу поделиться знаниями.

     

    Имеется следующая топология:

     

    Streamer > S3928GX-B > P3310B > P1501C1

     

    Суть проблемы в следуюшем, если клиентский IP адрес в той же сети, что и настроенный мультикаст влан интерфейс на S3928GX-B, тогда проблем нет, клиент нормально подписывается на мультикаст группы, подписки видны, как на OLT P3310B, так и на S3928GX-B.

     

    Но, если клиент получает свой IP адрес с другого влан (интернет) интерфейса, в этом случае подписка не доходит до S3928GX-B, хотя на OLT P3310B подписка есть в этом случае.

     

    Конфиг S3928GX-B:

    3928GX_config#show ru
    Building configuration...
    
    
    Current configuration:
    !
    !version 2.1.1A build 13295
    service timestamps log date
    service timestamps debug date
    !
    hostname 3928GX
    !
    !
    !
    !
    !
    !
    !
    no spanning-tree
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    aaa authentication login default local
    aaa authentication enable default none
    aaa authorization exec default local
    !
    username admin password 0 admin
    !
    !
    !
    ip multicast-routing
    !
    !
    interface Null0
    !
    interface GigaEthernet0/1
    !
    ----
    interface GigaEthernet0/21
    switchport trunk vlan-allowed 999,3333
    switchport mode trunk
    switchport pvid 3333
    ----
    interface TGigaEthernet1/1
    switchport trunk vlan-allowed 999,1111
    switchport mode trunk
    switchport pvid 1111
    !
    interface VLAN999
    ip address 10.12.12.12 255.255.255.0
    no ip directed-broadcast
    !
    interface VLAN1111
    ip address 10.10.10.100 255.255.255.0
    no ip directed-broadcast
    ip pim-sm
    ip igmp version 2
    !
    interface VLAN3333
    ip address 10.11.11.1 255.255.255.0
    no ip directed-broadcast
    ip pim-sm
    ip igmp enable
    ip igmp version 2
    !
    !
    !
    vlan 999
    name MNG 
    !
    vlan 1111
    name Stream
    !
    vlan 3333
    name Multicast
    !
    no ip igmp-proxy enable
    !
    ip route default 10.12.12.1
    ip exf
    !
    ipv6 exf
    !
    !
    !
    router pim-sm
    ------------

     

    Конфиг P3310B:

    interface GigaEthernet0/1
    switchport trunk vlan-allowed 999,3333
    switchport mode trunk
    switchport pvid 3333
    !
    interface EPON0/2
    epon bind-onu mac fcfa.f7ec.56fe 1
    switchport trunk vlan-allowed 999,3333
    switchport mode trunk
    !
    interface EPON0/2:1
    onu-configuration
     epon onu port 1 ctc vlan mode tag 999
     epon onu port 1 ctc mcst tag-stripe enable
     epon onu port 1 ctc mcst mc-vlan add 3333
    !!onu-configuration-end
    !
    !
    ip mcst enable
    ip mcst mrouter interface GigaEthernet0/1
    ip mcst mc-vlan 3333 range 239.10.10.1 - 239.10.10.254
    -----------

     

    Китайцы молчат уже неделю, буду очень благодарен за помощь!