Перейти к содержимому
Калькуляторы

artem.ultra

Пользователи
  • Публикации

    12
  • Зарегистрирован

  • Посещение

1 подписчик

О artem.ultra

  • Звание
    Абитуриент
  1. ping

    добрый день мог бы кто нибудь помочь написать скрипт. нужно все время пинговать ip, к примеру 8.8.8.8 при потере 2х пакетов, слать на почту мейл. буду очень признателен! :)
  2. делал резервирование по вот этой статье немножко отредачил скрипт, в основном ошибки форматирования вот что у меня получилось: :local MainIf isp1 :local RsrvIf isp2 :local PingCount 1 :local PingTargets {8.8.8.8; 8.8.4.4} :local MainIfInetOk false :local RsrvIfInetOk false :local MainPings 0 :local RsrvPings 0 foreach host in=$PingTargets do={ : local res [/ping $host count=$PingCount interface=$MainIf] : set MainPings ($MainPings + $res) : local res [/ping $host count=$PingCount interface=$RsrvIf] : set RsrvPings ($RsrvPings + $res) } :set MainIfInetOk ($MainPings >= 1) :set RsrvIfInetOk ($RsrvPings >= 1) :local MainGWDistance [/ip route get [find comment=MainGW] distance] :local RsrvGWDistance [/ip route get [find comment=RsrvGW] distance] if ($MainIfInetOk && ($MainGWDistance >= $RsrvGWDistance)) do={ /ip route set [find comment=MainGW] distance=1 /ip route set [find comment=RsrvGW] distance=2 foreach i in=[/ip firewall connection find] do={/ip firewall connection remove $i} /log info "switched to main internet connection" } if (!$MainIfInetOk && $RsrvIfInetOk && ($MainGWDistance = $RsrvGWDistance)) do={ /ip route set [find comment=MainGW] distance=2 /ip route set [find comment=RsrvGW] distance=1 foreach i in=[/ip firewall connection find] do={/ip firewall connection remove $i} /log info "switched to reserve internet connection" } при отключении шнурка, инет переключается на резерв и обратно, как бы все работает. но есть один подводный камень, есть sip телефоны, 20 шт. так вот они не перерегистрируются на серваке sad.gif опытным путем понял что телефоны не закрывают коннекты и ждут ответные пакеты со старого интерфейса (тот который я выдернул) к примеру: тоесть видно что телефон ждет ответ по не рабочему интерфейсу. если же этот коннект принудительно грохнуть через winbox телефон мигом делает перерегистрацию на серваке. вопрос, как через скрипт сбросить соединение? P.S в скрипте ведь есть строка по сбросу foreach i in=[/ip firewall connection find] do={/ip firewall connection remove $i} или это что то не то?
  3. wds

    что то я не могу понять как работает wireless access list signal strength range. создаю правило, указываю -78..120 а клиенты продолжают регистрироваться
  4. wds

    с одинаковым ssid'ом, а каналы разводить? или пускай эти ссиды будут на одном канале?
  5. wds

    спасибо! если обращусь!
  6. wds

    ну вы меня и озадачили:) ChargeSet можешь немного описать принцип построения? а то я что то уже запутался...
  7. wds

    переключение между точками. только очень туго. находясь возле точки на 8-мом этаже, телефон до последнего держит сигнал от 7-го этажа. при этом, этот сигнал очень слабый я немного не понял, при MESH, точки должны быть между собой соединены по шнурку?
  8. wds

    ну оно и так сейчас работает, только нужно на каждой точке создавать access list для wi-fi клиентов!
  9. wds

    хотел безшовку сделать для клиентов. и получается что если кто то поднимается с 7-го этажа, то автоматом он не переключается на точку на 8мом этаже. и у клиента уровень сигнала очень маленький (
  10. wds

    идея интересная, только не могу понять как будет работать wds
  11. wds

    да нет :( я сначала сам так подумал. но проверив не один раз, убедился что это мегабиты
  12. wds

    приветствую! имею в распоряжении 2 микротика rb951g-2hnd, нужно настроить раздачу интернета в офисном помещении. настроил два девайся через wds по этому мануалу ман проблема получилась в том, что внутренние тесты скорости микротика показывают скорость по wi-fi между ними всего лишь 2-5мбит\с, так же любые устройства которые присоединяются к этим точкам выше 2-5мбит\с не могут прогнать :( два девайся находятся друг над другом, между ними железобетонное перекрытие. так же если поставить два девайся в прямой видимости, то скорость выше не становится :( подскажите, так и должно быть? или я где то что то не до настроил?