Перейти к содержимому
Калькуляторы

sash_ko

Новичок
  • Публикации

    8
  • Зарегистрирован

  • Посещение

О sash_ko

  • Звание
    Абитуриент
  1. Debian wheezy и 10G

    Огромное спасибо за подсказку ;) Вобщем, перепробывал кучу методов, и получилось только в таком порядке: 1. Устанавил старый Debian 6.0 Squeeze 2. apt-get install iperf 3. Заменил squeeze на wheezy в sources.list 4. echo iperf hold | dpkg --set-selections 5. apt-get update 6. apt-get upgrade По началу была проблема с увеличением потерь UDP пакетов, решил её раскидыванием irq по ядрам + sysctl тюнинг. Сейчас iperf выдаёт вменяемые 5 Гб/с, но раньше всё ломалось и при использовании серва как маршрутизатора, что, к сожалению, пока что проверить не могу. Запущу пользователей как-нибудь, и поняблюдаю, о результатах обязательно отпишусь.
  2. Debian wheezy и 10G

    И ещё один момент, если заменить в sources.list слова squeeze на wheezy и сделать apt-get upgrade, у вас сразу же нарисуется потолок в 807 Mbps даже без перезагрузки. Сперва я думал что это из-за обновления iperf, но ведь как маршрутизатор он тоже понижает пропускную способность до тех же самых 807 Mbps... таких боков, тем более от дебиановцев, я точно не ожидал :)
  3. Debian wheezy и 10G

    Да. Народ, вобщем запилил ядро 3.11.4 на Debian 6 Squeeqe. И блин всё нормально! 5 Gbps UDP & 9.2 Gbps TCP. Так что теперь склоняюсь больше к написанию багрепорта на дебиановский багтрекер... Видимо есть какой-то неведомый процесс, который всё портит... Ибо на Debian 7 Wheezy никакие манипуляции с ядром и дровами не помагают, и не могу понять почему это именно 807 Mbps. Возможно это тупо баг, о котором никто не знает т.к., я думаю, не так много людей может поставить дистр на 10Г и потестить, зато 1Г есть у многих...
  4. accel pptpd

    Простите, туплю сегодня. Использовал старое ядро, сейчас взял 2.6.37.6, в котором, по идее, имеются нужные драйвера/модули для ацеля (было сказано что код включён начиная с RC1 2.6.37) Но теперь ацель просто тупо зависает после [2013-10-21 14:13:16]: warn: ppp: kernel doesn't support ipv6 Больше ничего не пишет, но и ничего не происходит. вставлял дебажный вывод в pppoe_init, но ничего не выводится, как будто до этого места вообще не доходит... Можете посоветовать ядро на котором всё будет хорошо при том что всё это дело будет не модульное, а встроенное? PS: для компиляции accel-ppp под новое ядро подменил -DKDIR для cmake
  5. accel pptpd

    Добрый день! Внезапно столкнулся с проблемой accel-ppp + custom kernel. При компиляции ядра встроил в него pppoe, ppp, ifb, htb, cbq, и много прочего что нужно для браса без поддержки IPv6. Но ацель ругается, говорит что хочет модули, и после нескольких секунд после старта просто завершает работу. Пробовал 1.7.2, 1.7.3, SVN версии Из логов пишет только в /var/log/accel-ppp/accel-ppp.log [2013-10-21 12:36:53]: warn: ppp: kernel doesn't support ipv6 [2013-10-21 12:36:53]: warn: failed to load pppoe kernel module [2013-10-21 12:37:09]: warn: failed to load ifb kernel module /var/log/accel-ppp/emerg.log shaper: ioctl(SIOCGIFINDEX): No such device в остальных логах пусто Если загрузить ядро в котором всё это добро таки модульное, никаких проблем не замечено UPD: Дико извиняюсь за невнимательность, IFB (Intermediate Functional Block device) всё-таки небыло встроено. Но появилась другая проблема: /var/log/accel-ppp/accel-ppp.log [2013-10-21 13:20:41]: warn: ppp: kernel doesn't support ipv6 [2013-10-21 13:20:41]: warn: failed to load pppoe kernel module [2013-10-21 13:20:54]: warn: failed to load ifb kernel module [2013-10-21 13:20:54]: msg: accel-ppp version d30c909bf845e359ec657f294af13d36cce46d06 ' [2013-10-21 13:21:08]: error: pppoe: connect: Bad file descriptor [2013-10-21 13:21:08]: info: : disconnected
  6. Debian wheezy и 10G

    2 Painter Проверил на эти сетевые карты с заданием полосы пропускания -b 1000M и 800M, и теперь если честно я вообще перестал понимать происходящее root@HOSTNAME:~# iperf -u -c IP_ADDR_HERE -i5 -t30 -b1G ------------------------------------------------------------ Client connecting to IP_ADDR_HERE, UDP port 5001 Sending 1470 byte datagrams UDP buffer size: 24.0 MByte (default) ------------------------------------------------------------ [ 3] local IP_ADDR_HERE port 7147 connected with IP_ADDR_HERE port 5001 [ ID] Interval Transfer Bandwidth [ 3] 0.0- 5.0 sec 637 MBytes 1.07 Gbits/sec ............................................................................... [ 3] Sent 2727068 datagrams [ 3] Server Report: [ 3] 0.0-30.3 sec 2.83 GBytes 803 Mbits/sec 7.799 ms 660674/2726945 (24%) root@HOSTNAME:~# iperf -u -c IP_ADDR_HERE -i5 -t30 -b800M ------------------------------------------------------------ Client connecting to IP_ADDR_HERE, UDP port 5001 Sending 1470 byte datagrams UDP buffer size: 24.0 MByte (default) ------------------------------------------------------------ [ 3] local IP_ADDR_HERE port 29892 connected with IP_ADDR_HERE port 5001 [ ID] Interval Transfer Bandwidth [ 3] 0.0- 5.0 sec 501 MBytes 840 Mbits/sec [ 3] Sent 2142771 datagrams [ 3] Server Report: [ 3] 0.0-30.1 sec 2.83 GBytes 807 Mbits/sec 0.012 ms 76506/2142770 (3.6%) [ 3] 0.0-30.1 sec 1 datagrams received out-of-order Потери уменьшаются с уменьшением траффика. Тобиж если всё-таки сгенерировать чистые 800Мбит, он их спокойно съест/пропустит, всё что выше улетит в ошибки. Причём интересно, что "ethtool -S" показывает, что ошибок ниразу нет, но при этом root@HOSTNAME:/home/USERNAME/ixgbe-3.17.3/src# netstat -su IcmpMsg: InType0: 1 InType3: 6 InType8: 72113 InType11: 2 OutType0: 72113 OutType3: 80 Udp: 7007437 packets received 4815420 packets to unknown port received. 14629383 packet receive errors 631 packets sent root@HOSTNAME:/home/USERNAME/ixgbe-3.17.3/src# uname -a Linux HOSTNAME 3.11.3 #15 SMP Tue Oct 8 13:24:34 EEST 2013 x86_64 GNU/Linux Сделал вывод что виноват Дебиан. Куда копать?
  7. Debian wheezy и 10G

    Нет, картина вообще никак не меняется при любых манипуляциях. Что интересно, iperf упирается в потолок в обоих сторонах, и на приём и на отдачу. Так же интересен фантастическая потеря пакетов (84% по вывод iperf), хотя если не снимая с места сверер откатить его до 2.6.35 ядра, никаких потерь и прочего непонятного поведения не наблюдается PS: заметил что при коспиляции драйвера от Интел, он жалуется на отсутствие функций DCA (direct cache access) root@HOSTNAME:~/ixgbe-3.17.3/src# make make -C /lib/modules/3.11.3/build SUBDIRS=/root/ixgbe-3.17.3/src modules make[1]: Entering directory `/home/USERNAME/linux-3.11.3' Building modules, stage 2. MODPOST 1 modules WARNING: "dca3_get_tag" [/root/ixgbe-3.17.3/src/ixgbe.ko] undefined! WARNING: "dca_register_notify" [/root/ixgbe-3.17.3/src/ixgbe.ko] undefined! WARNING: "dca_unregister_notify" [/root/ixgbe-3.17.3/src/ixgbe.ko] undefined! WARNING: "dca_add_requester" [/root/ixgbe-3.17.3/src/ixgbe.ko] undefined! WARNING: "dca_remove_requester" [/root/ixgbe-3.17.3/src/ixgbe.ko] undefined! make[1]: Leaving directory `/home/USERNAME/linux-3.11.3' но ведь со стандартным драйвером из коробки WHEEZY всё тоже самое :(
  8. Добрый день! Столкнулся со следующей проблемой: Имеется сервер IBM x3650 M2, в нём карточка Intel 82599EB (10 Gigabit). На сервере стоял Debian Squeeze, iperf демонстрировал 4.5Gbps TCP и 9.5Gbps UDP. Возникла необходимость обновить дебиан, и после обновления тесты iperf показывают 9.2Gbps TCP (что очень порадовало), НО 800Mbps UDP. Эту планку в 800 мегабит не удалось переплюнуть ни новым скомпилированным ядром, ни новым драйвером, не различными тюнингами sysctl и прочего. Доп инфа: на старом дебиане ядро 2.6.35, на новом 3.2.0, все последующие версии 3.х выдают одинаковый результат. Вопрос: что я делаю не так? Существует ли какое-либо ограничение в ядрах 3.х на UDP траффик? Как обойти? P.S.: Всё бы ничего, если бы это был бы только IPERF, но в продакшене с онлайном 2000+ людей он тоже упирается в потолок 800Mbits, при этом никаких нагрузок на CPU не замечено. При этом деб сквизи спокойно тащит 1.5Gbps root@HOSTNAME:/usr/local/etc/boot_config# uname -a Linux HOSTNAME 2.6.32-5-amd64 #1 SMP Fri May 10 08:43:19 UTC 2013 x86_64 GNU/Linux root@HOSTNAME:/usr/local/etc/boot_config# iperf -u -s ------------------------------------------------------------ Server listening on UDP port 5001 Receiving 1470 byte datagrams UDP buffer size: 24.0 MByte (default) ------------------------------------------------------------ [ 3] local IP_ADDR_HERE port 5001 connected with IP_ADDR_HERE port 34826 [ ID] Interval Transfer Bandwidth Jitter Lost/Total Datagrams [ 3] 0.0-30.0 sec 13.4 GBytes 3.84 Gbits/sec 0.005 ms 0/9805393 (0%) [ 3] 0.0-30.0 sec 1 datagrams received out-of-order root@HOSTNAME:~# uname -a Linux HOSTNAME 3.11.3 #2 SMP Mon Oct 7 10:52:20 EEST 2013 x86_64 GNU/Linux root@HOSTNAME:~# iperf -u -s ------------------------------------------------------------ Server listening on UDP port 5001 Receiving 1470 byte datagrams UDP buffer size: 24.0 MByte (default) ------------------------------------------------------------ [ 3] local IP_ADDR_HERE port 5001 connected with IP_ADDR_HERE port 50755 [ ID] Interval Transfer Bandwidth Jitter Lost/Total Datagrams [ 3] 0.0-30.2 sec 2.82 GBytes 801 Mbits/sec 15.121 ms 10811465/12870830 (84%)