Настройка VLAN между клиентами на OLT BDCOM P3310B

Доброго времени суток.

 

Столкнулся с проблемой настройки коммутироуемого VLAN между клиентами, подключенными к ONU.

Порты 3х ONU находятся в одном dot1q VLAN на одном PON SFP, при этом коммутация происходит только с хостами находящимися за аплинком OLT, т.е. с роутером и доступ в интернет у клиентов есть, однако, даже вышестоящий коммутатор не коммутирует клиентов, возможно потому что OLT режет обратную коммутацию по исходным макам.

Пробовал настраивать subnet-vlan, mac-based vlan и protocol-vlan, результатов ноль. Вменяемой документации, кроме http://doc.pavlabor.net/HARD/PON/BDCOM/Configuration%20Manual/07-VLAN%20Configuration.pdf не нашел.

Подскажите кто сталкивался, как победить.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Приведите схему сети, конфиг олта и сформулируйте ТЗ.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

я мало что понял и выше написанного ))

По догадкам - выключите ограничение общения между портами на ОНУ и на ОЛТ.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Схема такая, есть OLT BDCOM P3310B, которая подключена своим портом gigabitEthernet 0/1 через транзитный коммутатор к роутеру, который раздаёт интернет.

Со стороны PON в OLT подключен модуль SFP и через PLC сплитер подключены две ONU, все порты ONU настроены как access для VLAN 322.

VLAN 322 проходит через gigabitEthernet 0/1 и транзитный коммутатора к роутеру,

Управление OLT находится в VLAN 321.

Задача заключается в том, чтобы клиенты на различных ONU и находящиеся в одном VLAN получали доступ как к интернет, так и имели бы возможность взаимодействовать мжеду собой, т.е. находиться в одном широковещательном сегменте.

На данный момент, связь ONU с роутером через OLT и транзитный свитч, работает, однако клиенты не видят друг-друга.

Конфиг OLT:

!!slot 0 84

interface GigaEthernet0/1

switchport trunk vlan-allowed 2-4094

switchport mode trunk

!

interface GigaEthernet0/2

shutdown

!

interface GigaEthernet0/3

shutdown

!

interface GigaEthernet0/4

shutdown

!

interface GigaEthernet0/5

shutdown

!

interface GigaEthernet0/6

shutdown

!

interface EPON0/1

epon bind-onu mac fcfa.f796.2ad1 1

epon bind-onu mac fcfa.f796.5846 2

switchport mode trunk

switchport pvid 321

!

interface EPON0/1:1

onu-configuration

epon onu port 1 ctc vlan mode tag 322

epon onu port 2 ctc vlan mode tag 322

epon onu port 3 ctc vlan mode tag 322

epon onu port 4 ctc vlan mode tag 322

epon onu ip address static 10.1.3.2 255.255.255.0 gateway 10.1.3.254 vlan 321

epon onu port 1 loopback detect

epon onu port 1 storm-control mode 1 threshold 256

epon onu port 2 loopback detect

epon onu port 2 storm-control mode 1 threshold 256

epon onu port 3 loopback detect

epon onu port 3 storm-control mode 1 threshold 256

epon onu port 4 loopback detect

epon onu port 4 storm-control mode 1 threshold 256

!!onu-configuration-end

!

interface EPON0/1:2

onu-configuration

epon onu port 1 ctc vlan mode tag 322

epon onu port 2 ctc vlan mode tag 322

epon onu port 3 ctc vlan mode tag 322

epon onu port 4 ctc vlan mode tag 322

epon onu port 1 loopback detect

epon onu port 1 storm-control mode 1 threshold 256

epon onu port 2 loopback detect

epon onu port 2 storm-control mode 1 threshold 256

epon onu port 3 loopback detect

epon onu port 3 storm-control mode 1 threshold 256

epon onu port 4 loopback detect

epon onu port 4 storm-control mode 1 threshold 256

!!onu-configuration-end

!

interface EPON0/2

shutdown

!

interface EPON0/3

shutdown

!

interface EPON0/4

shutdown

!

!!slot end

!

interface VLAN321

ip address 10.1.3.1 255.255.255.0

!

!

!

vlan 322

name sfp1

subnet any

subnet 100.0.0.0 255.255.255.0

!

vlan 321-322

 

По догадкам - выключите ограничение общения между портами на ОНУ и на ОЛТ.

 

Да, отключить ограничение общения между ONU на OLT. Это то что мне нужно. Как это сделать ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

interface GigaEthernet0/1

switchport trunk vlan-untagged none

 

при необходимости тоже самое на interface EPON0/1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Не полная, но достаточная в этом случае информация содержится на диске от олта. Или не читали или невнимательно, что в принципе одно и тоже.

 

Дам решение вашей проблемы на договорной основе.

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Вова, ну чего ты его договариваться заставляеш? :) - Пускай лучше сам поищет как межонушечную сегментацию выключить.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Я просто не понимаю подобного поведения. Казалось вот тебе на плохом английском документация. Да, где-то сумбурная, где-то не полная, где-то от другого оборудования, да еще и покоцанная на кусочки, чтобы потенциальные читатели поиском мучались, но ведь есть!

 

Вот я и возмущен преступной халатностью.

 

P.S. Напоминает хирурга из моей поликлиники, который выписал препарат какой-то кальциевый, а на вопрос о режиме приема предложил самому почитать.

 

P.S.S. Мне скучно, дома сижу, и надо же как-то себя развлекать.

 

P.S.S.S. Команду я не помнил (мозг - не чердак), но нашлась она за минуту. Дольше на железку заходил.

Изменено пользователем passer

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Уважаемая публика решила поиздеваться, и показать своё преимущество в наличии тайного знания в достижении которого, надо хорошо покопать ?

Я не из тех людей, кому лень читать документацию, останавливает только одно - очень плотный график работы и отсутствие времени вникнуть. Я понимаю, что включается эта функция или отключается, каким-нибудь до абсурда простым способом, например одной опцией. Вопрос тем временем довольно острый сложился вокруг этой проблемы. И сюда я обратился не с просьбой к уважаемой публике, проштудировать доку за меня и дать мне ответ. Вопрос был обращён к тем, кто может и хочет помочь, т.е. как минимум, знает ответ на этот вопрос.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Вова, ну чего ты его договариваться заставляеш? :) - Пускай лучше сам поищет как межонушечную сегментацию выключить.

 

Спасибо, товарищ, почему-то именно ваш ответ помог найти решение.

 

Решается крайне просто, на интерфейсе EPON 0/1 надо включить опцию: epon inner-onu-switch

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

У меня аналогичный вопрос только по DASAN V5812G, пишу диплом по этому оборудованию, имеется 10 ONT, нужно чтобы они друг друга пинговали, в данный момент они все в 1 VLAN настройки делал по мануалу "Конфигурация GPON OLT и ONT — примеры первичной настройки OLT и ONT для оборудования SNR", только в этом году поступило оборудование, никто толком не разбирался еще и подсказать не может.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Решается крайне просто, на интерфейсе EPON 0/1 надо включить опцию: epon inner-onu-switch

 

Вот кстати перерыл все доки: http://data.nag.ru/BDCOM/Configuration%20Manual/3310/

Данную команду не нашел.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Здравствуйте.

Не получается заставить ONU-шки из одного PON порта видеть друг друга.

epon inner-onu-switch указал. Не помогает.

Пожалуйста, подскажите в чем может быть проблема.

 

OLT: P3310C

Версия по: 10.1.0E Build 36957

 

Конфиг:

Current configuration:

!

!version 10.1.0E build 36957

service timestamps log date

service timestamps debug date

service password-encryption

logging 192.168.100.50 informational

logging buffered 51200

logging buffered informational

!

hostname bdcom_olt

port-protected 1

!

!

ip default-gateway 172.21.0.1

!

!

no spanning-tree

!

!

aaa authentication login default local

aaa authentication enable default none

aaa authorization exec default local

!

username admin password 7 1330455C244F

!

!

 

epon oam-version 1 0x21

epon oam-version 2 0x20

!

epon onu-config-template t1

cmd-sequence 1 switchport port-security mode dynamic

cmd-sequence 2 switchport port-security dynamic maximum 2

cmd-sequence 3 epon onu all-port loopback detect

cmd-sequence 4 epon onu all-port ctc vlan mode tag 2100

!

!

!!slot 0 89

interface GigaEthernet0/1

shutdown

!

interface GigaEthernet0/2

shutdown

!

interface GigaEthernet0/3

shutdown

!

interface GigaEthernet0/4

shutdown

!

interface GigaEthernet0/5

description UPLINK

switchport trunk vlan-allowed 1000,1100,2100,4011

switchport trunk vlan-untagged none

switchport mode trunk

dhcp snooping trust

arp inspection trust

ip-source trust

!

interface GigaEthernet0/6

shutdown

!

interface EPON0/1

shutdown

no switchport protected

!

interface EPON0/2

epon pre-config-template t1 binded-onu-llid 1-64

epon bind-onu mac 1c87.7912.e7e7 1

epon bind-onu mac 1c87.7912.e7f6 2

switchport trunk vlan-allowed 1000,1100,2100,4011

switchport trunk vlan-untagged none

switchport mode trunk

no switchport protected

epon inner-onu-switch

!

interface EPON0/2:1

switchport port-security dynamic maximum 2

switchport port-security mode dynamic

epon onu port 1 ctc vlan mode tag 2100 priority 0

epon onu port 1 loopback detect

!

interface EPON0/2:2

switchport port-security dynamic maximum 2

switchport port-security mode dynamic

epon onu port 1 ctc vlan mode tag 2100 priority 0

epon onu port 1 loopback detect

!

interface EPON0/3

epon pre-config-template t1 binded-onu-llid 1-64

switchport trunk vlan-allowed 1000,2100

switchport trunk vlan-untagged none

switchport mode trunk

no switchport protected

epon inner-onu-switch

!

interface EPON0/4

shutdown

no switchport protected

!

!!slot end

!

interface VLAN1100

ip address 172.21.0.250 255.255.252.0

!

!

!

vlan 1100

name mgmnt

!

vlan 1,1000,1100,2100,4011

!

!

!

!

ip dhcp-relay snooping

ip dhcp-relay snooping vlan 1000,2100

ip arp inspection vlan 1000,2100

ip verify source vlan 1000,2100

ip dhcp-relay snooping information option

!

!

!

!

!

snmp-server community 0 public RO

snmp-server contact office

snmp-server location office

!

!

time-zone Moscow 3 0

ntp server 195.88.112.2

!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Здравствуйте.

Не получается заставить ONU-шки из одного PON порта видеть друг друга.

epon inner-onu-switch указал. Не помогает.

Пожалуйста, подскажите в чем может быть проблема.

Добрый день.

Команда inner-onu-switch, которую вы вводили, позволяет передавать трафик между ONU в рамках одного PON порта. Для передачи трафика между портами одной ONU вам нужно использовать команду no epon onu port-protect

В полном виде конфиг должен выглядеть примерно так

interface EPON0/2:1

epon onu port 1 ctc vlan mode tag 1249 priority 0

epon onu port 2 ctc vlan mode tag 1249 priority 0

epon onu port 3 ctc vlan mode tag 1249 priority 0

epon onu port 4 ctc vlan mode tag 1249 priority 0

epon onu port 1 ctc loopback detect

epon onu port 2 ctc loopback detect

epon onu port 3 ctc loopback detect

epon onu port 4 ctc loopback detect

no epon onu port-protect

epon onu port 1 ctc mcst tag-stripe enable

epon onu port 1 ctc mcst mc-vlan add 1500

epon onu port 1 ctc mcst max-group-number 10

epon onu port 2 ctc mcst tag-stripe enable

epon onu port 2 ctc mcst mc-vlan add 1500

epon onu port 2 ctc mcst max-group-number 10

epon onu port 3 ctc mcst tag-stripe enable

epon onu port 3 ctc mcst mc-vlan add 1500

epon onu port 3 ctc mcst max-group-number 10

epon onu port 4 ctc mcst tag-stripe enable

epon onu port 4 ctc mcst mc-vlan add 1500

epon onu port 4 ctc mcst max-group-number 10

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Подписчики 0