С такими железками дела не имел, но исходя из общей логики:

SNR-S2960-24G(config-if-vlan1)#ip default-gateway 192.168.5.1

Неправильный контекст, шлюз - настройка не влана а глобальная, должно быть

SNR-S2960-24G([b]config[/b])#ip default-gateway 192.168.5.1

 

SNR-S2960-24G#copy tftp://192.168.5.111/2960-24g.mib

% Incomplete command.

Не хватает второго параметра, куда копировать, что-то типа

SNR-S2960-24G#copy tftp://192.168.5.111/2960-24g.mib image-1

ЗЫ mib - оригинальное расширение для файла прошивки =)

Или это всё-таки SNMP-MIBs, но тогда зачем их заливать в коммутатор?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

С такими железками дела не имел, но исходя из общей логики:

SNR-S2960-24G(config-if-vlan1)#ip default-gateway 192.168.5.1

Неправильный контекст, шлюз - настройка не влана а глобальная, должно быть

SNR-S2960-24G([b]config[/b])#ip default-gateway 192.168.5.1

 

Да это я не доглядел. Уже несколько дней мучаюсь пытаясь понять логику, сильно от длинка отличается. Решил сделать буква в букву по инструкции, а там пунк перехода в глабольный пропущен :)

 

SNR-S2950-24G(config-if-vlan1)#ip address 10.10.10.1 255.255.255.0

Пропишем маршрут по умолчению

Switch(config)#ip default-gateway 10.10.10.254

Включаем интерфейс vlan 1

SNR-S2950-24G(config-if-vlan1)#no shu

Возвращаемся в "глобальный конфиг"

SNR-S2950-24G(config-if-vlan1)#exi

 

SNR-S2960-24G#copy tftp://192.168.5.111/2960-24g.mib

% Incomplete command.

Не хватает второго параметра, куда копировать, что-то типа

SNR-S2960-24G#copy tftp://192.168.5.111/2960-24g.mib image-1

ЗЫ mib - оригинальное расширение для файла прошивки =)

Или это всё-таки SNMP-MIBs, но тогда зачем их заливать в коммутатор?

 

Понял, что не тот файл схватил :) а про параметры опять же в инструкции ни слова:

 

Обновление ПО коммутатора производится командой

SNR-S2950-24G#copy tftp://10.10.10.10/nos.img nos.img

Confirm to overwrite the existed destination file? [Y/N]:y

Begin to receive file, please wait...

 

как я понял из веб интерфейса тут все таки нет параметра куда заливать. тут нужно указать путь/название файла от куда и название файла в свиче?

Изменено пользователем TIR52

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

SNR-S2960-48G(config)#firewall enable

SNR-S2960-48G(config)#access-list 1140 deny any-source-mac any-destination-mac untagged-eth2 window 12 2 8863 15 1 7

SNR-S2960-48G(config)#interface ethernet 0/0/1

SNR-S2960-48G(config-if-ethernet0/0/1)#mac access-group 1140 in

ERROR: user defined windows is not supported.

ERROR: can't bind access-list [1140] to interface Ethernet0/0/1!

 

linkey, да действительно, не получается привязать ACL к порту. Отправил запрос в R&D по вашей проблеме.

 

Решилась ли проблема ? Есть необходимость в подобных ACL.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Подскажите как сменить влан управление и ип адрес на свиче SNR-S2950-24G

аналог на дурных dlink des3028 conf ipif System ipaddres 10.101.254.1 vlan 66

Изменено пользователем Gunner

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Подскажите как сменить влан управление и ип адрес на свиче SNR-S2950-24G

аналог на дурных dlink des3028 conf ipif System ipaddres 10.101.254.1 vlan 66

 

Да там просто

1. Создаёте новый влан, прописываете его на транковых интерфейсах

2. Создаёте

int vlan XXX

ip addr ip_address mask

no shut

exit

3. Переписываете шлюз

4. Доступаетесь по новому адресу и удаляете старый int vlan. Ну и сам влан управления старый можно удалить.

Записать конфиг - wr

 

Два ip интерфейса одновременно точно работают.

 

А сколько максимум кстати?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Добрый день, у меня свитч SNR-S2940-8G

Урезанный конфиг

...
service dhcp
...
ip dhcp pool V333-1
host 192.168.10.10 255.255.255.0
hardware-address 00-00-00-00-00-00
lease 0 12 0
max-lease-time 0 12 0
default-router 192.168.10.1
dns-server 192.168.1.1
domain-name test
...
access-list 555 permit host-source-mac 00-00-00-00-00-00 any-destination-mac ip host-source 192.168.10.10 any-destination
access-list 555 deny any-source-mac any-destination-mac ip any-source any-destination
...
Interface Ethernet1/1
description port1
switchport access vlan 333
mac-ip access-group 555 in
switchport port-security
switchport port-security violation shutdown recovery 300
switchport port-security mac-address 00-00-00-00-00-00
...

 

стоит задача сделать так что бы если клиент подключается с любым другим МАС-адресом ему выдавало IP 192.168.10.222

конфигурацию можно менять, только одно требование - dhcp сервером должен выступать этот свич

Изменено пользователем snr-switch

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Всех с наступающим НГ, желаю больше положительных эмоций и всего наилучшего.

Может кто-то сделает подарок к елке и ответит на пост выше?)) спасибо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

подскажите, как автоматизировано конфиг с коммутатора собирать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Полностью слить конфиг с коммутатора можно по SNMP:

Перед сохранением конфигурации на TFTP-сервер, убедитесь в том, что пустой файл, в который будет сохраняться конфигурация, уже создан в папке TFTP-сервера.

1. Задаем IP-адрес TFTP-сервера:

snmpset -v2c -c private x.x.x.x .1.3.6.1.4.1.6339.100.1.10.3.0 s “y.y.y.y”

2. Задаем имя файла на коммутаторе:

snmpset -v2c -c private x.x.x.x .1.3.6.1.4.1.6339.100.1.10.4.0 s “startup.cfg”

3. Задаем имя файла на TFTP-сервере:

snmpset -v2c -c private x.x.x.x .1.3.6.1.4.1.6339.100.1.10.5.0 s “backup-current.cfg”

4. Устанавливаем тип сервера (1-FTP, 2-TFTP):

snmpset -v2c -c private x.x.x.x .1.3.6.1.4.1.6339.100.1.10.7.0 i 2

5. Запускаем процедуру загрузки (1-Upload, 2-Download):

snmpset -v2c -c private x.x.x.x .1.3.6.1.4.1.6339.100.1.10.8.0 i 1

Проверка статуса выполнения команды:

snmpget -v2c -c private x.x.x.x .1.3.6.1.4.1.6339.100.1.10.9.0

Результатом будет числовое значение текущего состояния:

0 - Error

1 - OK

2 - Uploading

3 - Downloading

4 - Idle

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Приветствую

 

Модель коммутатора SNR-S2960-24G. Актуален вопрос с блокировкой PADO с абонентских портов. Будет ли работать следующая конфигурация?

 

mac-access-list extended pado_security
 deny any-source-mac any-destination-mac untagged-eth2 ethertype 8863
 permit any-source-mac any-destination-mac
 exit

 

и на всех абонентских портах сделать

 

mac access-group pado_security in

 

Также интересует, как оставить только ssh доступ к коммутатору, на циске подобная конфигурация делается через line vty, тут же ничего подобного в режиме конфигурации я не нашёл.

Изменено пользователем cathode

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

cathode, Да сработает, только единственный момент - введите значение EtherType в десятичной системе счисления (0x8863 = 34915).

 

Также интересует, как оставить только ssh доступ к коммутатору, на циске подобная конфигурация делается через line vty, тут же ничего подобного в режиме конфигурации я не нашёл.

можно включить SSH и отключить Telnet:

ssh-server enable
no telnet-server enable

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Спасибо за подсказку со значением ethertype, фильтрация работает.

 

Но есть небольшая проблема, PADI пакет имеет тот же ethertype, что и PADO, соответственно PADI запросы от абонентов также режутся. Есть ли способ зарезать только PADO с абонентских портов (настраивается в целях безопасности)?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Посмотрите в сторону функционала PPPoE Intermediate Agent, описано в мануале - http://data.nag.ru/SNR%20Switches/Configuration%20Guide/SNR-S2960-24G/09-Security%20Function%20Configuration.pdf

Вкратце - аналог DHCP Snooping, только для PPPoE-пакетов

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

День добрый. Присматриваемся к вашей продукции. Взяли на тест несколько SNR-S2950-24G

Пробуем настроить на них защиту от колец в сети.

Получилась такая конструкция

SNR-S2950-24G#sh run
!
service password-encryption
!
hostname SNR-S2950-24G
sysLocation Ak.Vonsovskogo str. 1-118, Ekaterinburg, Russia
sysContact support@nag.ru
!
username admin privilege 15 password 7 4173cf767846af158bdfab07f06e803f
!
!
!
ssh-server enable
!
web language english
!
!
!
!
spanning-tree
!
!
!
sflow version 0
loopback-detection interval-time 10 3
!
!
loopback-detection trap enable
!
vlan 1;16
!
firewall enable
!
Interface Ethernet1/1
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/2
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/3
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/4
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/5
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/6
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/7
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/8
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/9
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/10
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/11
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/12
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/13
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/14
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/15
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/16
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/17
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/18
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/19
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/20
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/21
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/22
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/23
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/24
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/25
switchport mode trunk
!
Interface Ethernet1/26
switchport mode trunk
!
interface Vlan1
ip address 192.168.1.5 255.255.255.0
!
interface Vlan16
ip address 10.10.0.106 255.255.255.0
!
ip default-gateway 10.10.0.1
!
!
no login
!
end

SNR-S2950-24G#

 

С данными настройками ловит петлю "на себе" т.е. если взять патчкорд и воткнуть его обоими концами в SNR

Если же такой же патчкорд воткнуть обоими концами в другой свич и этот свич соединить с SNR - то петлю он уже не видит.

Какие еще настройки нужно внести?

Изменено пользователем Sacrament

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Проблемма такого рода

Есть проблемма создал Vlan 1, дал ему Ip адрес

создал vlan 1000 перенести управление.

ПОМОГИТЕ Желательно укажите команды какие вводить.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

День добрый. Присматриваемся к вашей продукции. Взяли на тест несколько SNR-S2950-24G

Пробуем настроить на них защиту от колец в сети.

Получилась такая конструкция

SNR-S2950-24G#sh run
!
service password-encryption
!
hostname SNR-S2950-24G
sysLocation Ak.Vonsovskogo str. 1-118, Ekaterinburg, Russia
sysContact support@nag.ru
!
username admin privilege 15 password 7 4173cf767846af158bdfab07f06e803f
!
!
!
ssh-server enable
!
web language english
!
!
!
!
spanning-tree
!
!
!
sflow version 0
loopback-detection interval-time 10 3
!
!
loopback-detection trap enable
!
vlan 1;16
!
firewall enable
!
Interface Ethernet1/1
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/2
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/3
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/4
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/5
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/6
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/7
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/8
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/9
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/10
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/11
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/12
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/13
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/14
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/15
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/16
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/17
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/18
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/19
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/20
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/21
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/22
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/23
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/24
switchport mode trunk
loopback-detection specified-vlan 1-4094
loopback-detection control shutdown
!
Interface Ethernet1/25
switchport mode trunk
!
Interface Ethernet1/26
switchport mode trunk
!
interface Vlan1
ip address 192.168.1.5 255.255.255.0
!
interface Vlan16
ip address 10.10.0.106 255.255.255.0
!
ip default-gateway 10.10.0.1
!
!
no login
!
end

SNR-S2950-24G#

 

С данными настройками ловит петлю "на себе" т.е. если взять патчкорд и воткнуть его обоими концами в SNR

Если же такой же патчкорд воткнуть обоими концами в другой свич и этот свич соединить с SNR - то петлю он уже не видит.

Какие еще настройки нужно внести?

 

Доброго времени суток. Если еще актуально.

 

conf

anti-arpscan enable

int eth(UPLINK)

anti-arpscan trust supertrust-port

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

а если в конфиге повыше int vlan16 добавить в vrf. будет доступен коммутатор по адресу в vrf по ssh/snmp ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Какой еще VRF на 2960? Там такого отроду небыло

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Добрый вечер!

Понадобилось на SNR-S2960-24G и SNR-S2960-48G завести учетки для суппорта с ограниченным функционалом, аналог user на д-линках.

Требуется смотреть счетчики пакетов, наличие линков, длину кабеля и текущий конфиг интерфейсов.

В доках в качестве privilege предлагают только 15, что явно излишне.

Правильно ли я понимаю, что 15й уровень избавляет от необходимости вводить пароль для enable?

Какой уровень посоветуете для получения необходимого функционала?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Хм, и правда циско-лайк :)

Спасибо, разобрался!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

а как работает функционал cluster? Хотелось бы получить stack аналогичный d-link из 2-х устройств SNR-S2980G-24F (раз уж стоят оба в одном ящике). Есть ли работающие примеры? Пробовал создавать - Set cluster commander error: create tcp server failure.

Если назначаю cluster ip-pool вылазит такая ошибка.

 

Конфиг на первой:

cluster run key mord1a

cluster ip-pool 10.10.15.1

cluster commander mord1a

cluster member mac-address f8-f0-82-10-08-45

 

 

На второй железке (mac f8-f0-82-10-08-45):

cluster run key mord1a

 

 

 

 

sh ver

SNR-S2980G-24F Device, Compiled on May 16 23:50:30 2013

sysLocation Ak.Vonsovskogo str. 1-118, Ekaterinburg, Russia

CPU Mac f8:f0:82:10:08:f9

Vlan MAC f8:f0:82:10:08:f8

SoftWare Version 7.0.3.1(R0058.0002)

BootRom Version 7.1.4

HardWare Version 1.0.1

CPLD Version N/A

Serial No.:N125001125

Copyright © 2013 NAG LLC

All rights reserved

Last reboot is warm reset.

Uptime is 0 weeks, 0 days, 0 hours, 32 minutes

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

заведен ли в новом свчите 2940-8g пользователь по умолчанию? адрес прописали на интерфейс, а аккаунт завести забыли, свитч уехал далеко на узел..

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

здравствуйте на коммутаторе SNR-S2940-8G через вэб интерфейс поменялось привилегия пользователя. Подскажите как через тел нет теперь мне вернуть на 15й уровень. Мануал читал но у меня таких команд коммутатор почемуто не понимает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

заведен ли в новом свчите 2940-8g пользователь по умолчанию? адрес прописали на интерфейс, а аккаунт завести забыли, свитч уехал далеко на узел..

По умолчанию admin admin, должен быть.

 

здравствуйте на коммутаторе SNR-S2940-8G через вэб интерфейс поменялось привилегия пользователя. Подскажите как через тел нет теперь мне вернуть на 15й уровень. Мануал читал но у меня таких команд коммутатор почемуто не понимает.

Сбросить конфиг?

http://shop.nag.ru/article/snr-s294029502960-faq

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Здравствуйте.

 

Что случилось с 2950 и 2960 ? Перестал заливаться конфиг через ftp. Долго висит, а потом ошибку копирования выдаёт в putty.

 

 

331 Password required for anonymous

230 Logged on

200 Type set to I

200 Port command successful

150 Opening data channel for file download from server of "/upload/103.cfg"

226 Successfully transferred "/upload/103.cfg"

Recv total 6740 bytes

421 Connection timed out.

Copy operation error!

Close ftp client.

 

 

И все они с новой прошивкой. Раньше всё нормально заливалось

Изменено пользователем Tirrr

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!


Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.


Войти
Подписчики 0