Прошивка от 12092015 последняя на данный момент. Забавный глюк: мерю скорость по WiFi до прошики с ноута. ноут цепляется в режиме N 72/150 зависит от карты. скорость 30-50мбит. Прошиваю со сбросом RWFS. Ноут цепляется в режиме B 11 мбит. Помогает только принудительный перевод в режим "только n". Сбрасывать не пробовал, т.к. настраивать потом не хочется. Особенно с неустраненным до сих пор глюком с DHCP. Эффект повторен десяток раз с разными ноутами и устройствами. Ща посмотрел на телефоне - оказывается тоже 11 мбит, а я и не замечаю. Чет сломали вы в последнем обновлении.

 

Глюк с DHCP (во всех прошивках) : при смене адреса устройства, диапазон адресов DHCP не меняется.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Я не знаю что вы накрутили но по такому описанию разбирайтесь без меня. Никакого глюка с ни с DHCP ни с 11Мбит никакими нет, и вообще по дефолту B режим запрещён.

 

Без номеров версий, без логов и т.д. это вам к гадалкам,не ко мне.

 

Глюк с DHCP (во всех прошивках) : при смене адреса устройства, диапазон адресов DHCP не меняется.

 

1) И не должен

2) Выводиться запрос а не сменить ли его

 

И вас ничего не натолкнуло на мысль что если бы действительно бы сваливалось быв CCK (11мбит возможны только в B режиме) то тут бы уже вой стоял,да и я бы это внезапно заметил т.к. сам пользуюсь тем же железом.

 

Сбрасывать не пробовал, т.к. настраивать потом не хочется.

 

Позвольте я тогда вас снесу в оффтоп и посажу в RO т.к. с подземными стуками разбираься не хочется.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Специально для вас.

Певрый девайс:

C4:85:08:B2:34:55	08:32:28	1	NO	3	15	40MHz	NO	NO	NO	HTMIX	-55,-68	Disconnect
00:13:E8:72:DB:75	08:32:25	2	NO	3	15	40MHz	NO	NO	NO	HTMIX	-71,-73

 

Второй девайс:

F8:A9:D0:79:1D:65	00:00:56	1	YES	3	7	20MHz	NO	YES	NO	HTMIX	-39,-27	Disconnect
48:A2:2D:21:61:32	00:00:13	2	NO	0	7	40MHz	NO	YES	NO	HTMIX	-51,-51

 

Клиенты разные. Софт "последний" от 12го, специально для вас залил.

 

Что-то вы нарукоблудили. Так что сброс настроек и настройка с включенной головой по шагам с проверкой на каждом этапе. Получите повтор на каком-то этапе будем смотреть, пока только к гадалкам. Чинить то что не ломалось это не ко мне.

 

Помогает только принудительный перевод в режим "только n".

 

G/N по дефолту вот его и юзайте. Ни в 802.11G ни в 802.11N нет 11Мбит.

 

Специально для вас перевёл в B/G/N (хотя этот режим нужен только для совместимости с оооооооооочень старыми клиентами которые даже G не могут).

48:A2:2D:21:61:32	00:00:14	1	NO	0	7	40MHz	NO	YES	NO	HTMIX	-51,-49	Disconnect
F8:A9:D0:79:1D:65	00:00:01	2	YES	3	7	20MHz	NO	YES	NO	HTMIX	-33,-35

 

В общем спасибо что отняли моё время, а то мне без вас заняться не чем было.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

И да, ознакомьтесь пожалуйста http://forum.nag.ru/forum/index.php?showtopic=103978, ибо в заданном вами ключе я точно не готов общаться и тратить на вас своё время, для подземных стуков есть support@nag.ru, сюда будьте добры с логами, и всеми необходимыми попутными данными.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Извините что отнял у вас такое драгоценное время. У нас в парке около 1000 таких роутеров. И я их обслуживаю. И всегда считал, что железо классное, прошивка еще лучше. И в принципе всегда прошивал на последнюю не заморачиваясь с проверкой параметров. Хорошо, что сбрасывать не надо на заводские при прошивке. Но вчера конкретно появилась проблема со скоростью у абонента. Я померял до прошивки (11012015 кажется) и прошил последнюю. Потом померял и не понял. Скорость упала до 5 мбит. Ну начал разбираться и вычислил проблему описаную выше. У меня дома стоит такой же вот параметры: прошивка 09092015 клиент Lenovo P780

MAC Address 	CONN TIME 	AID 	PSM 	MIMO PS 	MCS 	BW 	SGI 	STBC 	LDPC 	MODE 	RSSI 	ACTIONS
C8:DD:C9:xx:xx:xx	00:06:49	1	YES	0	3	20MHz	NO 	NO 	NO 	CCK	-38,-34	

параметры вайфая
Network Mode (2.4GHz) 	 g/n
Channel BandWidth 	20/40
HT TxStream 	2
HT RxStream 	2
MCS 	auto
Guard Interval 	auto
Space-Time Block Coding 	en
Aggregation MSDU 	en
Auto Block ACK 	en
Decline Block ACK Request 	dis
Reverse Direction Grant 	en

BG Protection Mode 	auto
Beacon Interval 100	ms (range 20 - 999)
Data Beacon Rate 50	ms (range 1 - 255)
Fragment Threshold 2346	(range 256 - 2346)
RTS Threshold 2347	(range 1 - 2347)
Maximum clients per SSID 32	(1 - 32)
Station Keep-Alive 30	s (10 - 300)
Idle Timeout 160	s (60 - 300)
Short Preamble 	Enable  
Short Slot 	Enable  
Tx Burst 	Enable  
Pkt Aggregate 	Enable  
WMM Capable 	Enable  
Country Region Code 	5

Прошил сейчас 18092015 ничего не поменялось. Попробую сбросить.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Нашел в чем глюк. При дефолте нормальная скорость 135. При включении RDG падает до 121. При включении второго SSID подключается только на 11 мбит. Это особенности стандарта или глюк прошивки?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А зачем вы включаете RDG? С включением второго SSID проверю, не должно быть проблем, но допускаю что при перепиливании рожи внесли регрессию. А RDG имеет смысл включать если у вас есть клиенты на Ralink.

 

Извините что отнял у вас такое драгоценное время.

 

Просто описывать надо сразу проблему с данными со всеми иначе смысла писать сюда нет, только время тратите которого и так нет даже на те задачи которые уже начаты. Должны понимать что если я буду играть в угадайку то заниматься ПО у меня времени не останется. Нас всего 2 человека, имейте совесть, вроде не домоюзеры должны уметь багрепорты писать и не выёживаться сбрасывать не буду потому что лень.

 

Включил 2 SSID, подключился к первому:

48:A2:2D:21:61:32	00:00:45	1	NO	0	7	40MHz	NO	YES	NO	HTMIX	-40,-45

Ко второму:

48:A2:2D:21:61:32	00:00:08	1	NO	0	7	40MHz	NO	YES	NO	HTMIX	-47,-48

Включил RDG

48:A2:2D:21:61:32	00:00:04	1	NO	0	7	40MHz	NO	YES	NO	HTMIX	-52,-50

 

 

Не вижу в упор проблемы.

 

Конфиг с глюком скиньте гляну.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Проверил как формируется nvram при 2х SSID - всё в норме... Так что жду конфиг.

В драйверах ничего такого что могло повлиять только в режиме с >1 SSID не правилось, т.е. либо настройки не верно формируются либо я ХЗ. Повторить пока не удалось.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Похоже я нашёл что может приводить к этому делу. Сейчас проверю если что соберу поправленную версию.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Ужас какой бедлам на тему GN в 2.7 драйвере. В 2.5 помню я уже это всё чинил, тут смотрю трындец. В новом уже тожепофиксили (та ветка что test-only). Я тупанул и проверил на ней.

 

В общем проблема с G/N чистым при включенном MBSSID поймана. Вариант юзать либо чистый N либо B/G/N пока не починю, либо не юзать MBSSID. Сейчас если с наскока зафикшу то хорошо. Просто уже не хочется тратить время на старый драйвер, нужно в новом шероховатости закрыть и на него переезжать а то ща на это дело убью время в пустую.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Так, залечил вроде собираю 3.5.3 с фиксом. Желательно сброс и настройка с нуля либо просто зайти в BasicWireless и нажать Apply.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Залил 3.5.3 с фиксом, проверяйте, отписывайте.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Залил 3.5.3 с фиксом, проверяйте, отписывайте.

 

Да, все нормально.Скорость в порядке. И без Apply.

 

MAC Address 	CONN TIME 	AID 	PSM 	MIMO PS 	MCS 	BW 	SGI 	STBC 	LDPC 	MODE 	RSSI 	ACTIONS
C8:DD:C9:хх:хх:хх	00:02:19	3	YES	0	7	40MHz	NO 	YES	NO 	HT	-48,-47	

Изменено пользователем Sterr

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

прошивка на MT-7620 SNR-CPE-W4N-MT-3.7.4.RU.10122015

сломан механизм генерации SSH-ключей, возможно из-за использования нестандартного порта

 

после каждой перезагрузки ключи у коробки новые, SSH-клиент ругается

 

IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the DSA key sent by the remote host is
f0:18:42:8b:2a:81:5b:04:6b:ef:02:5f:97:bb:1e:3f.
Please contact your system administrator.
Add correct host key in /Users/user/.ssh/known_hosts to get rid of this message.
Offending DSA key in /Users/user/.ssh/known_hosts:50
DSA host key for [192.168.1.1]:582 has changed and you have requested strict checking.
Host key verification failed.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Не сломан. Я отказался от прегенерации. Т.е. генериться при первом запросе подключения по ssh (в rwfs не сохраняется). Т.е. что бы ключ зафиксировать (например что бы приюзать автоматизацию управления по ssh) достаточно после первого входа сказать fs save. Сделано чисто из соображений секурности (всегда "свежий" ключ если не сказали сохранить принудительно). Оно уже месяца 4ре как так.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Здавствуйте! Я ваша ... ой :)

На двух рутерах (SNR-CPE-W4N-MT-3.9.21.RU.17022016) проявилось следующее: ставлю нестандартный порт web, в частности 8888, применяю... и затем не могу подключиться, пока не перезагружу рутер. Интернет через маршрутизатор, при этом, работает. После перезагрузки(выкл/вкл питание) цепляюсь нормально к порту 8888. Проверил обратное: с нестандартного порта возвращаю на 80 - и тоже теряю возможность зайти в морду.

 

(регресс или нет - не знаю, но на укропах такого вроде не было).

 

Хочу добавить, маршрутизатор при этом не перезагружается, хотя и пишет что будет перезагружен. Доступ по старому порту также теряется. (после перезагрузки, как я писал, нормально работает уже на новом порту). Пробовал эксплорером и хромом, снаружи и изнутри - не влияет

Изменено пользователем termos

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Ещё заметка: после смены LAN IP, умная шелезяка предлагает подкрутить настройки dhcpd, мы соглашаемся, и всё здорово срабатывает, но хотелось бы, чтобы Start IP address оканчивался на 2ку (сейчас - на 0), а END IP Address - 254 (сейчас 255).

Спасибки.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Проверю, возможно да регрессия.

 

По диапазонам надо Дэна пнуть. Но он до сих пор занят. Придумаем что-нить.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Перестала работать ранее сделанная кастомизация для однобендовых коробок MT-7620.

Конкретнее после команды вливания параметров из файла

nvram_renew 2860 /etc/custom/nvram_set

и последующей перезагрузки коробка теряет IP. И только сброс по кнопке её оживляет.

Более точно не могу диагностировать т.к. коробка становится недоступной. причем WiFi в эфире светится и даже подключается с WPA2, но поскольку коробка на IP не отвечает (в ARP-кеше тоже нет её IP) ничего больше сказать не могу.

 

Ранее до версии 3.3.8 никаких проблем не наблюдалось.

файлик /etc/custom/nvram_set содержит только малую часть параметров а не все, может в этом причина?

Ну или параметры в новых версиях как-то конфликтуют..

Пример файлика прикрепляю, параметры все те что заливаю.

nvram_set.txt

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Бббр, расскажите что и как вы делаете. Чёт не совсем въехал. Нет ну я могу смотреть и гадать конечно по содержимому. Однако я бы не стал бы делать как вы, а менял бы только нужные переменные (т.к. nvram меняется время от времени, добавляются новые параметры). Самый простой способ тупо в скрипте заливаемом через rwfs вызывать nvram_set.

 

Навскидку не помню что бы менял формат каких-то значений что бы конфиги стали несовместимыми.

 

Завтра гляну ваш конфиг, но ещё раз грю, не стоит юзать renew, меняйте только те параметры которые нужно через nvram_set.

 

P.S. Если не сложно заведите одну коробку с распаянным UART`ом, что бы можно было глянуть что происходит когда устройство по сети недоступно. Сильно поможете. Зарание спасибо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

файлик /etc/custom/nvram_set содержит только малую часть параметров а не все, может в этом причина?

 

 

Ааа. Ну блин... Всё ясно. Я пофиксил багу с занулением полей в итоге у вас поломалось то, что работало из-за баги. =))))) Ну в общем переделайте и вместо вызова renew делайте nvram_set для нужных вам параметров (это будет работать с любой версией). renew и т.д. эт чисто внутренняя сервисная логика, лучше её не юзать.

 

Да и вообще замена полей более универсальна. Я почешу репу как сделать удобный вариант merge. Но пока так.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Спасибо, я примерно так и предполагал причину потери функционала своей кастомизации.

При вставке каждого параметра отдельной командой ведь количество перезаписей nvram будет равно количеству этих параметров, что по идее не так уж и хорошо. Или я не прав?

Может мне лучше подождать реализации merge ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Не беспокойтесь я каждый день пишу не по одной сотне раз и флэши всё ещё живы. Современный NOR не так просто убить. Это не NAND однако. Лет на 10ть вам хватит хоть каждый день пиши по сотне параметров. В общем не заморачивайтесь на тему погибели флэша от столь лёгкого насилия. =)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Firmware Version SNR-CPE-W4N-MT-4.1.2.RU.21032016

 

Попробовал залить параметры отдельными командами

 

nvram_set 2860 Language ru
nvram_set 2860 CHECKMAC YES
nvram_set 2860 WAN_MAC_ADDR F8:F0:82:51:12:DB
nvram_set 2860 ApCliSsid Test-1111
nvram_set 2860 HostName Test-1111
nvram_set 2860 SmbNetBIOS Test-1111
nvram_set 2860 SSID1 Test-1111
nvram_set 2860 WPAPSK1 F8F0825112DB
nvram_set 2860 CountryCode RU
nvram_set 2860 CountryRegion 5
nvram_set 2860 CountryRegionABand 0
nvram_set 2860 EncrypType AES
nvram_set 2860 AuthMode WPA2PSK
...

 

Всё применяется без вопросов и ругани, но после перезагрузки всё такая же шляпа с недоступностью коробки. Почему-то IP коробки становится недоступным, хотя судя по светящемуся SSID и успешном подключении к WiFi вносимые в коробку параметры кастомизации работают, хотя на WiFi так же не выдается адрес через DHCP.

Таки придется паять UART...

Кстати проверил - все вносимые мною параметры есть в дефолтном конфиге

 

p.s.

Можете сами внести параметры из файлика и посмотреть что происходит при загрузке, у меня ошибка воспроизводится на 100%.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!


Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.


Войти