Вы Гость ( Вход | Регистрация )

OSPF конфигурация на примере кольца. Страница 1 из 1 опции темы

Пользователь офлайн antaeus
20 августа 2010 - 11:42
Сообщение #1

Звание: Абитуриент
Группа: Участник
Сообщений: 74
Регистрация: 21 апреля 10
есть конфигурация, роутры в кольце, хотим оттестировать как все будет перекладываться в обе стороны.

конфигурация freebsd

Цитата

Current configuration:
!
hostname zebra
log file /tmp/ospfd.log
log syslog
!
debug zebra events
debug ospf event
debug ospf packet all detail
!
password 123
enable password 123
!
interface fwe0
ipv6 nd suppress-ra
!
interface fwip0
ipv6 nd suppress-ra
!
interface lo0
!
interface re0
ipv6 nd suppress-ra
!
interface re0.951
ip ospf cost 10
ipv6 nd suppress-ra
!
interface sk0
ip ospf cost 10
ip ospf priority 255
ipv6 nd suppress-ra
!
router ospf
ospf router-id 10.254.233.1
redistribute kernel metric 10 metric-type 1 route-map ospf-out
redistribute connected metric 10 metric-type 1 route-map ospf-out
redistribute static metric 10 metric-type 1 route-map ospf-out
network 10.254.233.0/24 area 0.0.0.0
default-information originate metric 5 metric-type 1
!
ip prefix-list filter_list seq 5 permit 10.254.0.0/16 ge 32
ip prefix-list filter_list seq 10 deny any
!
route-map ospf-out permit 5
match ip address prefix-list filter_list
!
ip forwarding
!
line vty
exec-timeout 0 0
!
end

конфигурация r1

Цитата

Current configuration:
!
log file /tmp/ospfd.log
!
password zebra
enable password zebra
!
interface ath0
!
interface eth0
ip ospf priority 200
!
interface eth0_real
!
interface eth1_real
!
interface gre0
!
interface lo
!
interface wifi0
!
router ospf
ospf router-id 10.254.233.2
ospf abr-type shortcut
redistribute kernel metric 20 metric-type 1 route-map ospf-out
redistribute connected metric 20 metric-type 1 route-map ospf-out
redistribute static metric 20 metric-type 1 route-map ospf-out
network 10.254.228.0/24 area 0.0.0.2
network 10.254.233.0/24 area 0.0.0.0
area 0.0.0.3 virtual-link 10.254.228.2
default-information originate always
!
access-list vty-list deny any
!
ip prefix-list filter_list seq 5 permit 10.254.0.0/16 le 32
ip prefix-list filter_list seq 10 deny any
!
route-map ospf-out permit 5
match ip address prefix-list filter_list
!
ip forwarding
ipv6 forwarding
!
line vty
access-class vty-list
exec-timeout 0 0
!
end
конфигурация r2

Цитата

Current configuration:
!
log file /tmp/ospfd.log
!
password zebra
enable password zebra
!
interface ath0
!
interface eth0
!
interface eth0_real
!
interface eth1_real
!
interface gre0
!
interface lo
!
interface wifi0
!
router ospf
ospf router-id 10.254.228.2
ospf abr-type standard
redistribute kernel metric 20 metric-type 1 route-map ospf-out
redistribute connected metric 20 metric-type 1 route-map ospf-out
redistribute static metric 20 metric-type 1 route-map ospf-out
network 10.254.228.0/24 area 0.0.0.2
network 10.254.229.0/24 area 0.0.0.3
area 0.0.0.2 virtual-link 10.254.233.2
!
access-list vty-list deny any
!
ip prefix-list filter_list seq 5 permit 10.254.0.0/16 le 32
ip prefix-list filter_list seq 10 deny any
!
route-map ospf-out permit 5
match ip address prefix-list filter_list
!
ip forwarding
ipv6 forwarding
!
line vty
access-class vty-list
exec-timeout 0 0
!
end


конфигурация r3

Цитата

Current configuration:
!
log file /tmp/ospfd.log
!
password zebra
enable password zebra
!
interface ath0
!
interface eth0
!
interface eth0_real
!
interface eth1_real
!
interface gre0
!
interface lo
!
interface wifi0
!
router ospf
ospf router-id 10.254.233.3
ospf abr-type standard
redistribute kernel metric 20 metric-type 1 route-map ospf-out
redistribute connected metric 20 metric-type 1 route-map ospf-out
redistribute static metric 20 metric-type 1 route-map ospf-out
network 10.254.230.0/24 area 0.0.0.4
network 10.254.233.0/24 area 0.0.0.0
area 0.0.0.4 virtual-link 10.254.230.2
default-information originate metric 10 metric-type 1
!
access-list vty-list deny any
!
ip prefix-list filter_list seq 5 permit 10.254.0.0/16 le 32
ip prefix-list filter_list seq 10 deny any
!
route-map ospf-out permit 5
match ip address prefix-list filter_list
!
ip forwarding
ipv6 forwarding
!
line vty
access-class vty-list
exec-timeout 0 0
!
end

конфигурация r4

Цитата

Current configuration:
!
log file /tmp/ospfd.log
!
password zebra
enable password zebra
!
interface ath0
!
interface eth0
!
interface eth0_real
!
interface eth1_real
!
interface gre0
!
interface lo
!
interface wifi0
!
router ospf
ospf router-id 10.254.230.2
ospf abr-type standard
redistribute kernel metric 20 metric-type 1 route-map ospf-out
redistribute connected metric 20 metric-type 1 route-map ospf-out
redistribute static metric 20 metric-type 1 route-map ospf-out
network 10.254.229.0/24 area 0.0.0.3
network 10.254.230.0/24 area 0.0.0.4
area 0.0.0.4 virtual-link 10.254.233.3
default-information originate metric 10 metric-type 1
!
access-list vty-list deny any
!
ip prefix-list filter_list seq 5 permit 10.254.0.0/16 le 32
ip prefix-list filter_list seq 10 deny any
!
route-map ospf-out permit 5
match ip address prefix-list filter_list
!
ip forwarding
ipv6 forwarding
!
line vty
access-class vty-list
exec-timeout 0 0
!
end



Изначальная проблема на r2 и r3 не приходят дефолтные маршруты, сделали виртуальные линки между r1 <-> r2 и r4 <-> r3, все равно не приходят...

Сообщение отредактировал antaeus: 20 августа 2010 - 11:47

Прикрепленные файлы

  • Прикрепленный файл  ospf2.png (15,3К)
    Количество загрузок:: 44
 
Пользователь офлайн visir
21 августа 2010 - 13:06
Сообщение #2

Звание: Аспирант
Группа: Активный участник
Сообщений: 984
Регистрация: 20 марта 06
Используйте только area 0, и все будет хорошо. Дополнительные area здесь совершенно не нужны.
 
Пользователь офлайн cmhungry
21 августа 2010 - 14:14
Сообщение #3

Звание: Аспирант
Группа: VIP
Сообщений: 1 049
Регистрация: 03 марта 06

Просмотр сообщенияantaeus (20 августа 2010 - 11:42) писал:

есть конфигурация, роутры в кольце, хотим оттестировать как все будет перекладываться в обе стороны.
"каждая ареа должна быть присоединена к 0". Правило №1 оспф-дизайна.
На 10 рутеров биться по ариям нет никакого смысла вообще, пишите все в 0 и не парьтесь, +1 к Визиру
 
Пользователь онлайн Abram
23 августа 2010 - 01:51
Сообщение #4

Звание: Доцент
Группа: VIP
Сообщений: 1 324
Регистрация: 14 мая 09
Вогнать все роутеры в один L2-сегмент, а для кольца - STP. И нечего городы городить ;).
 
Пользователь офлайн antaeus
23 августа 2010 - 10:26
Сообщение #5

Звание: Абитуриент
Группа: Участник
Сообщений: 74
Регистрация: 21 апреля 10
да, по идее правильно все в одну арея, или как минимум чтобы все были смежными с area0
нопросто хотелось бы попробовть так (это стенд, а не рабочая сеть) использовал виртуальные линки, но они не работали (
не правильно видимо использовал ).

тем не менее спасибо за ответы.

Сообщение отредактировал antaeus: 23 августа 2010 - 10:46

 
Пользователь онлайн Abram
23 августа 2010 - 14:18
Сообщение #6

Звание: Доцент
Группа: VIP
Сообщений: 1 324
Регистрация: 14 мая 09
Если попробовать - то Core 2 Quad, VirtualBox и дистрибутив Mikrotik Вам в руки :). Я когда-то BGP на подобной топологии проверял, когда изучал. Просто на Mikrotik проще всего поднять.
Можно ещё gns3/dynagen. А можно и то, и то вместе ;-).
 
Пользователь офлайн antaeus
23 августа 2010 - 15:04
Сообщение #7

Звание: Абитуриент
Группа: Участник
Сообщений: 74
Регистрация: 21 апреля 10

Просмотр сообщенияAbram (23 августа 2010 - 14:18) писал:

Если попробовать - то Core 2 Quad, VirtualBox и дистрибутив Mikrotik Вам в руки :). Я когда-то BGP на подобной топологии проверял, когда изучал. Просто на Mikrotik проще всего поднять.
Можно ещё gns3/dynagen. А можно и то, и то вместе ;-).
для экспериментов с cisco использую Packet Tracer (он есть как в .exe, так и в .deb), gns3 - тяжел, раб станция не очень мощная.
а на существующем стенде rocket m5 и freedsb.

OSPF на самом деле на много сложнее, чем кажется на первый взгляд. поэтому продолжаю изучать =)
 
Пользователь онлайн Abram
23 августа 2010 - 18:25
Сообщение #8

Звание: Доцент
Группа: VIP
Сообщений: 1 324
Регистрация: 14 мая 09

Просмотр сообщенияantaeus (23 августа 2010 - 15:04) писал:

Просмотр сообщенияAbram (23 августа 2010 - 14:18) писал:

Если попробовать - то Core 2 Quad, VirtualBox и дистрибутив Mikrotik Вам в руки :). Я когда-то BGP на подобной топологии проверял, когда изучал. Просто на Mikrotik проще всего поднять.
Можно ещё gns3/dynagen. А можно и то, и то вместе ;-).
для экспериментов с cisco использую Packet Tracer (он есть как в .exe, так и в .deb), gns3 - тяжел, раб станция не очень мощная.
а на существующем стенде rocket m5 и freedsb.
Насколько я помню, Packet Tracer - симулятор (т.е. реально пакетики не коммутируются), а dynagen - эмулятор (эмулируется железо, на котором запускается IOS). Потому и разница в весе.
 
Пользователь офлайн antaeus
23 августа 2010 - 18:30
Сообщение #9

Звание: Абитуриент
Группа: Участник
Сообщений: 74
Регистрация: 21 апреля 10
ну да, но разница не критична, в моем случае. на своем ПК я не смогу запустить в dynagen 5 копий IOS.
 
Пользователь офлайн s.lobanov
23 августа 2010 - 21:01
Сообщение #10

Звание: Профессор
Группа: VIP
Сообщений: 4 240
Регистрация: 23 февраля 10

Просмотр сообщенияantaeus (23 августа 2010 - 18:30) писал:

ну да, но разница не критична, в моем случае. на своем ПК я не смогу запустить в dynagen 5 копий IOS.

Разница критична. В packet tracer очень много багов, я когда сдавал лабы на нём, обплевался весь.
 
Пользователь офлайн sauron
25 августа 2010 - 06:42
Сообщение #11

Звание: Абитуриент
Группа: Участник
Сообщений: 14
Регистрация: 15 октября 04
Город: Курган
В случае если у вас STP еще на кольце есть, то не забудьте поменять dead-interval. По умолчанию он составляет 60 секунд, что в случае перестройки STP может приводить еще и к перестройке OSPF.
 
Пользователь офлайн YanZyi
21 сентября 2010 - 18:03
Сообщение #12

Звание: Абитуриент
Группа: Пользователи
Сообщений: 1
Регистрация: 21 сентября 10

Просмотр сообщенияAbram (23 августа 2010 - 01:51) писал:

Вогнать все роутеры в один L2-сегмент, а для кольца - STP. И нечего городы городить ;).
Предлагаемое решение (использовать STP) сводит на нет все преимущества сети на протоколе OSPF, а именно, скорость пересчета маршрутов в случае изменений в топологии сети. STP работает очень медленно, в худшем случае порт поднимается 50 секунд, в лучшем случае - около 30 секунд, которые нужны для прохождения промежуточных состояний Listening и Learning (см. 802.1D). OSPF же способен при правильной структуризации сети обеспечивать переключение трафика на альтернативные маршруты за время порядка 800 мс в худшем случае, чего не может даже RSTP - относительно быстрый протокол построения активных путей коммутации.
 
Страница 1 из 1
  • Вы не можете создать новую тему
  • Вы не можете ответить в тему

1 человек читают эту тему
0 пользователей, 1 гостей, 0 скрытых пользователей